]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/aubergine.nix
home-manager: add delete-generations
[julm/julm-nix.git] / hosts / aubergine.nix
1 { config, pkgs, lib, inputs, ... }:
2 {
3 imports = [
4 ../nixos/profiles/server.nix
5 #../nixos/profiles/debug.nix
6 ../nixos/profiles/lang-fr.nix
7 #../nixos/profiles/tor.nix
8 aubergine/hardware.nix
9 aubergine/networking.nix
10 aubergine/nginx.nix
11 aubergine/backup.nix
12 aubergine/sftp.nix
13 ];
14
15 # Lower kernel's security for better performances
16 boot.kernelParams = [ "mitigations=off" ];
17
18 home-manager.users.julm = {
19 imports = [ ../homes/julm.nix ];
20 };
21 users = {
22 users.julm = {
23 isNormalUser = true;
24 uid = 1000;
25 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
26 # which is already world readable.
27 # printf %s $(mkpasswd -m yescrypt)
28 hashedPassword = lib.readFile aubergine/users/julm/login/hashedPassword.clear;
29 extraGroups = [
30 "adbusers"
31 "dialout"
32 "networkmanager"
33 "tor"
34 "wheel"
35 ];
36 # If created, zfs-mount.service would require:
37 # zfs set overlay=yes ${hostName}/home
38 createHome = true;
39 openssh.authorizedKeys.keys = map lib.readFile [
40 ../users/root/ssh/losurdo.pub
41 ../users/julm/ssh/losurdo.pub
42 ../users/julm/ssh/oignon.pub
43 ../users/julm/ssh/redmi.pub
44 ];
45 };
46 users.root = {
47 hashedPassword = "!";
48 openssh.authorizedKeys.keys =
49 config.users.users.julm.openssh.authorizedKeys.keys;
50 };
51 users.sevy = {
52 isNormalUser = true;
53 uid = 1001;
54 hashedPassword = "!";
55 extraGroups = [
56 ];
57 # If created, zfs-mount.service would require:
58 # zfs set overlay=yes ${hostName}/home
59 createHome = true;
60 openssh.authorizedKeys.keys = map lib.readFile [
61 ../users/sevy/ssh/patate.pub
62 ];
63 };
64 };
65
66 #systemd.services.nix-daemon.serviceConfig.LoadCredentialEncrypted =
67 # "secret-key-files:" + aubergine/nix/secret-key-files;
68 nix = {
69 extraOptions = ''
70 #secret-key-files = /run/credentials/nix-daemon.service/secret-key-files.pem
71 '';
72 settings = {
73 substituters = [
74 #"http://nix-localcache.losurdo.wg"
75 #"ssh://nix-ssh@losurdo.wg?priority=30"
76 #"ssh://nix-ssh@oignon.wg?priority=30"
77 ];
78 trusted-public-keys = map lib.readFile [
79 ../users/root/nix/oignon.pub
80 ];
81 };
82 nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
83 };
84 #environment.etc."nixpkgs".source = pkgs.path;
85 #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
86
87 nix.settings.allowed-users = [ config.users.users."nix-ssh".name ];
88 nix.sshServe = {
89 enable = true;
90 keys = map lib.readFile [
91 ../users/julm/ssh/losurdo.pub
92 ../users/sevy/ssh/patate.pub
93 ../users/julm/ssh/oignon.pub
94 ];
95 };
96
97 environment.systemPackages = [
98 ];
99
100 boot.extraModulePackages = [
101 #config.boot.kernelPackages.v4l2loopback
102 ];
103
104 # This value determines the NixOS release with which your system is to be
105 # compatible, in order to avoid breaking some software such as database
106 # servers. You should change this only after NixOS release notes say you should.
107 system.stateVersion = "22.11"; # Did you read the comment?
108 }