]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/hardware/X200.nix
nix: use latest nixosSystem
[julm/julm-nix.git] / nixos / profiles / hardware / X200.nix
1 { config, ... }:
2 {
3 imports = [
4 ./thinkpad.nix
5 ];
6
7 nixpkgs.hostPlatform = {
8 system = "x86_64-linux";
9 config = "x86_64-unknown-linux-gnu";
10 };
11
12 # tp_smapi works on ThinkPads made before 2013. See compat table:
13 # https://www.thinkwiki.org/wiki/Tp_smapi#Model-specific_status
14 boot.kernelModules = [ "tp_smapi" ];
15 boot.extraModulePackages = with config.boot.kernelPackages; [ tp_smapi ];
16 }