]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: add white-on-black and black-on-white
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, config, ... }:
2 {
3 programs.bash = {
4 enable = lib.mkDefault true;
5 shellAliases = {
6 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
7 c = "bat";
8 cl = "clear";
9 eic = "edit-in-commit";
10 eigg = "edit-in-git-grep";
11 emacs = "emacsclient --create-frame";
12 g = "git";
13 gg = "git grep";
14 grep = "grep --color";
15 j="sudo journalctl -u";
16 jb="sudo journalctl -b";
17 l = "ls -alh";
18 ll = "ls -al";
19 ls = "ls --color=tty";
20 md-toc = "grep '^#\\+' --color";
21 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
22 mem-top = "smem --sort rss --autosize";
23 mpl = "mplayer";
24 nixos-clean="sudo nix-collect-garbage -d";
25 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
26 nixos-rollback="sudo nixos-rebuild switch --rollback";
27 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
28 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
29 s="sudo systemctl";
30 st="sudo systemctl status";
31 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
32 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
33 u="systemctl --user";
34 ut="systemctl --user status";
35 watch = "watch --color --differences";
36 yt = "yt-dlp";
37 zfs-umount = "zfs-unmount";
38 };
39 initExtra = ''
40 shopt -s globstar
41 shopt -s histreedit
42 shopt -s histverify
43 # Disable ctrl-s/ctrl-q flow control
44 stty -ixon
45
46 ibm-fan () {
47 if [ $# -gt 0 ]
48 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
49 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
50 fi
51 acpi -t
52 }
53 mkcd () {
54 mkdir -p "$1" &&
55 cd "$1"
56 }
57 smartctl-tbw () {
58 device=''${1:-/dev/sda}
59 sudo smartctl -A $device |
60 { awk '
61 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
62 $0 ~ /Total_LBAs_Written/ {
63 lbas = $10;
64 bytes = $10 * 512;
65 mb = bytes / 1024^2;
66 gb = bytes / 1024^3;
67 tb = bytes / 1024^4;
68 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
69 printf "mean writes per hour: / %.2f", mb/poh
70 }
71 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
72 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
73 '; echo; } |
74 sed -e 's:/:@:' |
75 sed -e "s\$^\$$device @ \$" |
76 column -ts@
77 }
78 swaplist () {
79 lastpid=
80 swap=0
81 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
82 while IFS=: read -r file x size x
83 do
84 pid=''${file#/proc/}
85 pid=''${pid%/smaps}
86 size=''${size% kB}
87 size=''${size##* }
88 if test "$pid" = "$lastpid"
89 then swap=$(( swap + size ))
90 else
91 if test "$swap" -gt 0
92 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
93 fi
94 if test "$pid" = self
95 then break
96 else
97 lastpid=$pid
98 swap=$size
99 fi
100 fi
101 done |
102 sort -nk1,1
103 }
104 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
105 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
106 zfs-mount () { for d in $(zfs list -rH -o name "$@"); do sudo zfs mount -l "$d"; done; }
107 zfs-unmount () { sudo zfs unmount -u "$@"; }
108 '';
109 profileExtra = ''
110 '';
111 };
112 programs.direnv.enableBashIntegration = true;
113 #programs.broot.enableBashIntegration = true;
114 home.sessionVariables = {
115 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
116 };
117 programs.readline = {
118 enable = lib.mkDefault true;
119 includeSystemConfig = true;
120 bindings = {
121 "\\eOF" = "end-of-line";
122 "\\eOH" = "beginning-of-line";
123 "\\e[1;5C" = "forward-word";
124 "\\e[1;5D" = "backward-word";
125 "\\e[1~" = "beginning-of-line";
126 "\\e[4~" = "end-of-line";
127 "\\e[5C" = "forward-word";
128 "\\e[5D" = "backward-word";
129 "\\e[7~" = "beginning-of-line";
130 "\\e[8~" = "end-of-line";
131 "\\e[A" = "history-search-backward";
132 "\\e[B" = "history-search-forward";
133 "\\e[F" = "end-of-line";
134 "\\e[H" = "beginning-of-line";
135 "\\e\\e[C" = "forward-word";
136 "\\e\\e[D" = "backward-word";
137 };
138 variables = {
139 colored-completion-prefix = lib.mkDefault true;
140 colored-stats = lib.mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
141 echo-control-characters = lib.mkDefault true;
142 mark-symlinked-directories = lib.mkDefault true;
143 menu-complete-display-prefix = lib.mkDefault true;
144 show-all-if-ambiguous = lib.mkDefault true;
145 show-all-if-unmodified = lib.mkDefault true;
146 visible-stats = lib.mkDefault false; # Append char to indicate type
147 };
148 };
149 }