5 enable = mkDefault true;
7 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
10 eic = "edit-in-commit";
11 eigg = "edit-in-git-grep";
12 emacs = "emacsclient --create-frame";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
20 ls = "ls --color=tty";
21 md-toc = "grep '^#\\+' --color";
22 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
23 mem-top = "smem --sort rss --autosize";
25 nf = "sudo nft list ruleset | less";
26 nixos-clean = "sudo nix-collect-garbage -d";
27 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
28 nixos-rollback = "sudo nixos-rebuild switch --rollback";
29 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
31 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
33 st = "sudo systemctl status";
34 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
35 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
36 u = "systemctl --user";
37 ut = "systemctl --user status";
38 w1 = "watch --color --differences --interval 1";
39 w5 = "watch --color --differences --interval 5";
40 w10 = "watch --color --differences --interval 10";
41 w = "watch --color --differences";
42 watch = "watch --color --differences";
44 zfs-umount = "zfs-unmount";
47 HISTCONTROL = "erasedups:ignorespace";
49 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
53 . ${pkgs.complete-alias}/bin/complete_alias
54 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
60 # Disable ctrl-s/ctrl-q flow control
65 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
66 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
75 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
78 device=''${1:-/dev/sda}
79 sudo smartctl -A $device |
81 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
82 $0 ~ /Total_LBAs_Written/ {
88 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
89 printf "mean writes per hour: / %.2f", mb/poh
91 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
92 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
95 sed -e "s\$^\$$device @ \$" |
98 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
99 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
100 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
104 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
105 while IFS=: read -r file x size x
111 if test "$pid" = "$lastpid"
112 then swap=$(( swap + size ))
114 if test "$swap" -gt 0
115 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
117 if test "$pid" = self
127 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
128 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
130 # Recursively mount not-mounted dataset,
131 # loading their keys if needed.
133 for d in $(zfs list -rH -o name "$@"); do
134 mountpoint /mnt/"$d" 2>/dev/null ||
135 sudo zfs mount -l "$d"
138 # Recursively unmount dataset,
139 # unloading their keys.
140 zfs-unmount () { sudo zfs unmount -u "$@"; }
142 # Restore the inheritance of encryptionroot,
143 # usually broken by zfs send --raw.
144 # Note that it needs to decrypt the datasets.
145 zfs-fix-encryptionroot () {
147 for i in $(zfs list -rHo name "$1" | tail -n +2); do
149 test "$(zfs get -Ho value encryptionroot $i)" = "$1" ||
150 zfs change-key -li "$i"
157 programs.direnv.enableBashIntegration = true;
158 #programs.broot.enableBashIntegration = true;
159 programs.readline = {
160 enable = mkDefault true;
161 includeSystemConfig = true;
164 "\\e[A" = "history-search-backward";
165 "\\e[B" = "history-search-forward";
167 # Ctrl-Left/Ctrl-Right
168 "\\e[1;5C" = "forward-word";
169 "\\e[1;5D" = "backward-word";
170 "\\e[5C" = "forward-word";
171 "\\e[5D" = "backward-word";
172 "\\e\\e[C" = "forward-word";
173 "\\e\\e[D" = "backward-word";
176 "\\e[1~" = "beginning-of-line";
177 "\\e[4~" = "end-of-line";
180 "\\e[3~" = "delete-char";
181 "\\e[2~" = "quoted-insert";
183 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
184 "\\eOF" = "end-of-line";
185 "\\eOH" = "beginning-of-line";
187 # For freebsd console
188 "\\e[F" = "end-of-line";
189 "\\e[H" = "beginning-of-line";
192 "\\e[7~" = "beginning-of-line";
193 "\\e[8~" = "end-of-line";
194 "\\eOc" = "forward-word";
195 "\\eOd" = "backward-word";
200 input-meta = mkDefault true;
201 output-meta = mkDefault true;
202 colored-completion-prefix = mkDefault true;
203 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
204 echo-control-characters = mkDefault true;
205 mark-symlinked-directories = mkDefault true;
206 menu-complete-display-prefix = mkDefault true;
207 show-all-if-ambiguous = mkDefault true;
208 show-all-if-unmodified = mkDefault true;
209 visible-stats = mkDefault false; # Append char to indicate type
210 enable-bracketed-paste = mkDefault true;