7 # error: phantomjs 1.9.8 has been dropped due to lack of maintenance and security issues
11 xdg.configFile."yt-dlp/config".text = ''
12 #--download-archive .downloaded
16 --format ${lib.concatStringsSep "/" [
17 "bestvideo[height<=480][vcodec=av1]+bestaudio"
18 "bestvideo[height<=480][vcodec=vp9]+bestaudio"
19 "bestvideo[height<=480][ext=mp4]+bestaudio"
20 "bestvideo[height<=480]+bestaudio"
22 "best[height<=480][ext=av1]"
23 "best[height<=480][ext=vp9]"
24 "best[height<=480][ext=mp4]"
29 --output "%(release_date>%Y-%m-%d,upload_date>%Y-%m-%d)s - %(title)s.%(id)s.%(format_id)s.%(ext)s"
30 --match-filter !is_live
32 --sub-format ass/srt/best
33 --sub-langs "en.*,fr,-live_chat,-rechat"
34 --user-agent Mozilla/5.0