]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/aubergine/networking/wifi.nix
aubergine: nftables: enable forwarding to/from wifi
[julm/julm-nix.git] / hosts / aubergine / networking / wifi.nix
1 { pkgs, lib, hostName, ... }:
2 with (import ./names-and-numbers.nix);
3 {
4 environment.systemPackages = [
5 pkgs.iw
6 ];
7 networking.interfaces = {
8 ${wifiIface} = {
9 useDHCP = false;
10 ipv4.addresses = [{ address = "${wifiIPv4}.1"; prefixLength = 24; }];
11 ipv4.routes = [
12 {
13 address = "${wifiIPv4}.0";
14 prefixLength = 24;
15 options = { congctl = "westwood"; };
16 }
17 ];
18 };
19 };
20 networking.nftables.ruleset = lib.mkAfter ''
21 table inet filter {
22 chain input {
23 iifname ${wifiIface} jump input-lan
24 iifname ${wifiIface} log level warn prefix "input-lan: " counter drop
25 }
26 chain output {
27 oifname ${wifiIface} jump output-lan
28 oifname ${wifiIface} log level warn prefix "output-lan: " counter drop
29 }
30 chain forward-to-wifi {
31 accept
32 }
33 chain forward-from-wifi {
34 accept
35 }
36 chain forward {
37 iifname { ${eth1Iface}, ${eth2Iface}, ${eth3Iface} } oifname ${wifiIface} goto forward-to-wifi
38 iifname ${wifiIface} oifname { ${eth1Iface}, ${eth2Iface}, ${eth3Iface} } goto forward-from-wifi
39 }
40 }
41 '';
42
43 networking.networkmanager.unmanaged = [ wifiIface ];
44 services.dnscrypt-proxy2.settings.listen_addresses = [ "${wifiIPv4}.1:53" ];
45 systemd.services.dhcpd4.onFailure = [ "network-addresses-${wifiIface}.service" ];
46 services.dhcpd4 = {
47 enable = true;
48 interfaces = [ wifiIface ];
49 extraConfig = ''
50 subnet ${wifiIPv4}.0 netmask 255.255.255.0 {
51 range ${wifiIPv4}.100 ${wifiIPv4}.200;
52 option broadcast-address ${wifiIPv4}.255;
53 option domain-name-servers ${wifiIPv4}.1;
54 option routers ${wifiIPv4}.1;
55 option subnet-mask 255.255.255.0;
56 }
57 '';
58 };
59 # iw dev wlp5s0 station dump
60 # DOC: https://w1.fi/cgit/hostap/plain/hostapd/hostapd.conf
61 services.hostapd = {
62 enable = true;
63 logLevel = 2;
64 interface = wifiIface;
65 # 0 means the AP will search for the channel with the least interferences (ACS)
66 channel = 1;
67 hwMode = "g";
68 ssid = hostName;
69 wpa = false;
70 #wpaPassphrase = "bidonpoissonmaisonronron";
71 countryCode = "FR";
72 extraConfig = ''
73 # WLAN
74 beacon_int=100
75 dtim_period=2 # DTIM (delivery trafic information message)
76 preamble=1
77 # limit the frequencies used to those allowed in the country
78 ieee80211d=1
79
80 # WPA2
81 #wpa_key_mgmt=WPA-PSK
82 #wpa_pairwise=CCMP
83 #rsn_pairwise=CCMP
84 #auth_algs=1 # 0=noauth, 1=wpa, 2=wep, 3=both
85 macaddr_acl=0
86 # QoS support, also required for full speed on 802.11n/ac/ax
87 wmm_enabled=1
88 eap_reauth_period=360000
89 wpa_group_rekey=600
90 wpa_ptk_rekey=600
91 wpa_gmk_rekey=86400
92
93 # N-WLAN
94 ieee80211n=1
95 # See Capabilities in iw list
96 #ht_capab=[HT40+][SHORT-GI-40][DSSS_CCK-40][MAX-AMSDU-3839]
97 require_ht=1
98 obss_interval=0
99
100 # 802.11ac support
101 ieee80211ac=0
102 '';
103 };
104
105 }