]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/lang-zh.nix
fcitx5: enable chinese
[julm/julm-nix.git] / home-manager / profiles / lang-zh.nix
1 { config, pkgs, ... }:
2 {
3 i18n.inputMethod = {
4 enabled = "fcitx5";
5 fcitx5.addons = [
6 # Be sure to select « rime » and not « chinese » in fcitx5-configtool
7 pkgs.fcitx5-rime
8 pkgs.fcitx5-gtk
9 pkgs.libsForQt5.fcitx5-chinese-addons
10 ];
11 };
12 #waylandFrontend = true;
13 home.packages = [
14 pkgs.noto-fonts
15 pkgs.noto-fonts-lgc-plus
16 pkgs.noto-fonts-cjk-sans
17 pkgs.noto-fonts-cjk-serif
18 pkgs.noto-fonts-color-emoji
19 pkgs.noto-fonts-emoji-blob-bin
20 # ExplanationNote: superseded by jigmo
21 #pkgs.hanazono
22 pkgs.jigmo
23 ];
24 xdg.configFile."fcitx5/conf/classicui.conf".text = ''
25 PerScreenDPI=False
26 Font="Jigmo Regular 40"
27 #Theme=Material-Color-Black
28 '';
29 xdg.configFile."fcitx5/conf/pinyin.conf".text = ''
30 CloudPinyinEnabled=False
31 '';
32 xdg.configFile."fcitx5/conf/rime.conf".text = ''
33 PreeditInApplication=True
34 '';
35 }