]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/courge.nix
fcitx5: enable chinese
[julm/julm-nix.git] / hosts / courge.nix
1 {
2 config,
3 pkgs,
4 lib,
5 inputs,
6 hostName,
7 ...
8 }:
9 {
10 imports = [
11 ../nixos/profiles/graphical.nix
12 ../nixos/profiles/lang-fr.nix
13 ../nixos/profiles/laptop.nix
14 ../nixos/profiles/printing.nix
15 courge/backup.nix
16 courge/hardware.nix
17 courge/networking.nix
18 ];
19
20 # Lower kernel's security for better performances
21 security.kernel.mitigations = "off";
22
23 home-manager.users.mo = {
24 imports = [ ../homes/mo.nix ];
25 };
26 users.users.root = {
27 openssh.authorizedKeys.keys = map lib.readFile [
28 ../users/julm/ssh/oignon.pub
29 ../users/julm/ssh/losurdo.pub
30 ];
31 };
32 users.users.mo = {
33 isNormalUser = true;
34 uid = 1000;
35 # Put the hashedPassword in /nix/store,
36 # though /etc/shadow is not world readable...
37 # printf %s $(mkpasswd -m yescrypt)
38 hashedPassword = lib.readFile courge/users/mo/login/hashedPassword.clear;
39 extraGroups = [
40 "adbusers"
41 "dialout"
42 "lp"
43 "networkmanager"
44 #"plugdev" # For rtl-sdr
45 "scanner"
46 #"tor"
47 "video"
48 "wheel"
49 #"ipfs"
50 #config.services.davfs2.davGroup
51 #"vboxusers"
52 ];
53 # If created, zfs-mount.service would require:
54 # zfs set overlay=yes ${hostName}/home
55 createHome = false;
56 openssh.authorizedKeys.keys = map lib.readFile [
57 ../users/julm/ssh/oignon.pub
58 ../users/julm/ssh/losurdo.pub
59 ];
60 };
61
62 environment.systemPackages = [
63 #pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
64 ];
65
66 boot.extraModulePackages = [
67 ];
68
69 #programs.fuse.userAllowOther = true;
70
71 services.xserver = {
72 desktopManager = {
73 gnome.enable = true;
74 };
75 displayManager = {
76 gdm.enable = true;
77 };
78 };
79
80 services.displayManager = {
81 defaultSession = "gnome";
82 autoLogin = {
83 user = config.users.users.mo.name;
84 };
85 };
86
87 # This value determines the NixOS release with which your system is to be
88 # compatible, in order to avoid breaking some software such as database
89 # servers. You should change this only after NixOS release notes say you should.
90 system.stateVersion = "23.05"; # Did you read the comment?
91 }