11 ../nixos/profiles/graphical.nix
12 ../nixos/profiles/lang-fr.nix
13 ../nixos/profiles/laptop.nix
14 ../nixos/profiles/printing.nix
20 # Lower kernel's security for better performances
21 security.kernel.mitigations = "off";
23 home-manager.users.mo = {
24 imports = [ ../homes/mo.nix ];
27 openssh.authorizedKeys.keys = map lib.readFile [
28 ../users/julm/ssh/oignon.pub
29 ../users/julm/ssh/losurdo.pub
35 # Put the hashedPassword in /nix/store,
36 # though /etc/shadow is not world readable...
37 # printf %s $(mkpasswd -m yescrypt)
38 hashedPassword = lib.readFile courge/users/mo/login/hashedPassword.clear;
44 #"plugdev" # For rtl-sdr
50 #config.services.davfs2.davGroup
53 # If created, zfs-mount.service would require:
54 # zfs set overlay=yes ${hostName}/home
56 openssh.authorizedKeys.keys = map lib.readFile [
57 ../users/julm/ssh/oignon.pub
58 ../users/julm/ssh/losurdo.pub
62 environment.systemPackages = [
63 #pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
66 boot.extraModulePackages = [
69 #programs.fuse.userAllowOther = true;
80 services.displayManager = {
81 defaultSession = "gnome";
83 user = config.users.users.mo.name;
87 # This value determines the NixOS release with which your system is to be
88 # compatible, in order to avoid breaking some software such as database
89 # servers. You should change this only after NixOS release notes say you should.
90 system.stateVersion = "23.05"; # Did you read the comment?