1 { pkgs, lib, config, ... }:
5 nixpkgs.hostPlatform = {
6 system = "x86_64-linux";
7 config = "x86_64-unknown-linux-gnu";
10 hardware.cpu.amd.updateMicrocode = mkDefault config.hardware.enableRedistributableFirmware;
11 powerManagement.cpuFreqGovernor = mkDefault "ondemand";
13 # Too CPU hungry for this hardware, for too little MiB saved
14 nix.settings.auto-optimise-store = false;
16 # https://insanity.industries/post/sata-power-consumption/
17 services.udev.extraRules = ''
18 SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
25 configurationLimit = mkDefault 1;
27 # In case canTouchEfiVariables doesn't work
28 #efiInstallAsRemovable = true;
30 # Completed in the importing configuration
34 { devices = [ "${disk_id}" ];
35 path = "/boot${bootnum}";
42 canTouchEfiVariables = true;
43 efiSysMountPoint = "/boot/efi";
49 availableKernelModules = [
59 # Enable to switch to stage-2 from the SD card
64 boot.consoleLogLevel = mkDefault 7;
67 "console=ttyS0,115200n8"
68 # Use arc_summary to print stats
69 #"zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
72 environment.systemPackages = [