1 { pkgs, lib, config, ... }:
2 let inherit (lib) types;
3 inherit (config.networking) hostName domain;
9 defaults/predictable-interface-names.nix
12 #binaryCaches = lib.mkForce [];
15 autoOptimiseStore = lib.mkDefault true;
16 # Use gc.automatic to keep disk space under control.
18 automatic = lib.mkDefault true;
19 dates = lib.mkDefault "weekly";
20 options = lib.mkDefault "--delete-older-than 30d";
22 nixPath = lib.mkForce [];
24 environment.variables.NIXPKGS_CONFIG = lib.mkForce "";
26 documentation.nixos = {
27 enable = lib.mkDefault false; # NOTE: useless on a server, and CPU intensive.
30 console.font = "Lat2-Terminus16";
31 console.keyMap = lib.mkDefault "fr";
32 i18n.defaultLocale = "fr_FR.UTF-8";
33 nixpkgs.config.allowUnfree = false;
34 time.timeZone = "Europe/Paris";
36 # Always try to start all the units (default.target)
37 # because systemd's emergency shell does not try to start sshd.
38 # https://wiki.archlinux.org/index.php/systemd#Disable_emergency_mode_on_remote_host
39 systemd.enableEmergencyMode = false;
41 # This is a remote headless server: always reboot on a kernel panic,
42 # to not have to physically go power cycle the apu2e4.
43 # Which happens if the wrong ZFS password is used
44 # but the boot is manually forced to continue.
45 # Using kernelParams instead of kernel.sysctl
46 # sets this up as soon as the initrd.
47 boot.kernelParams = [ "panic=10" ];
49 boot.cleanTmpDir = lib.mkDefault true;
50 boot.tmpOnTmpfs = lib.mkDefault true;
54 # See: https://github.com/NixOS/nixpkgs/issues/10183#issuecomment-537629621
56 "127.0.1.1" = lib.mkForce [ "${hostName}.${domain}" hostName ];
57 "::1" = lib.mkForce [ "${hostName}.${domain}" hostName "localhost" ];
60 usePredictableInterfaceNames = true;
66 MaxRetentionSec=1month
74 passwordAuthentication = false;
77 environment.systemPackages = with pkgs; [
80 config.boot.kernelPackages.cpupower
90 #mailutils # builds guile
110 environment.variables.SYSTEMD_LESS = "FKMRX";
111 environment.etc."inputrc".text = lib.readFile defaults/readline/inputrc;
115 interactiveShellInit = ''
116 bind '"\e[A":history-search-backward'
117 bind '"\e[B":history-search-forward'
119 # Ignore duplicate commands, ignore commands starting with a space
120 export HISTCONTROL=erasedups:ignorespace
121 export HISTSIZE=42000
123 # Append to the history instead of overwriting (good for multiple connections)
126 # Enable ** file pattern
130 mkcd() { mkdir -p "$1" && cd "$1"; }
131 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk '/MemAvailable/{ printf "%d\n", $2 * $fac; }' </proc/meminfo)k; }
132 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
133 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
134 zfs-mount () { for d in $(zfs list -rH -o name "$@"); do sudo zfs mount -l "$d"; done; }
135 zfs-unmount () { sudo zfs unmount -u "$@"; }
141 ls = "ls --color=tty";
142 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
143 mem-top = "smem --sort rss --autosize";
146 st="sudo systemctl status";
147 u="systemctl --user";
148 ut="systemctl --user status";
149 j="sudo journalctl -u";
151 nixos-clean="sudo nix-collect-garbage -d";
152 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
153 nixos-rollback="sudo nixos-rebuild switch --rollback";
156 gnupg.agent.pinentryFlavor = "curses";
157 mosh.enable = lib.mkDefault true;
158 mtr.enable = lib.mkDefault true;
159 traceroute.enable = lib.mkDefault true;