]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/carotte.nix
nix: enable nix.sshServe on losurdo
[sourcephile-nix.git] / hosts / carotte.nix
1 # NixOS configuration of carotte.sourcephile.fr
2 { inputs, hostName, ... }:
3 {
4 system = "x86_64-linux";
5 extraArgs = {
6 CPUs = 2;
7 };
8 modules = [
9 ../nixos/defaults.nix
10 ../nixos/profiles/systems/debug.nix
11 #carotte/fileSystems.nix
12 carotte/hardware.nix
13 carotte/networking.nix
14 carotte/security.nix
15 carotte/system.nix
16 carotte/users.nix
17 (inputs.secrets + "/hosts/${hostName}/users.nix")
18 carotte/xserver.nix
19 ];
20 }