1 { pkgs, lib, config, ... }:
3 hardware.cpu.amd.updateMicrocode = true;
5 # Too CPU hungry for the APU2, for too little Mio saved
6 autoOptimiseStore = false;
9 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
14 "vm.vfs_cache_pressure" = 50;
23 configurationLimit = 3;
25 # In case canTouchEfiVariables doesn't work
26 #efiInstallAsRemovable = true;
28 # Completed in the importing configuration
32 { devices = [ "${disk_id}" ];
33 path = "/boot${bootnum}";
40 canTouchEfiVariables = true;
41 efiSysMountPoint = "/boot/efi";
47 availableKernelModules = [
55 # Made the AES modules available at initrd,
56 # to speedup the deciphering of the root.
69 "console=ttyS0,115200n8"
70 # Use arc_summary to print stats
71 "zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
74 environment.systemPackages = [