]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet.nix
mermet: add nginx and fix stuffs
[sourcephile-nix.git] / servers / mermet.nix
1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 { pkgs, lib, config, options
6 # NixOps extra module inputs
7 , nodes, name, uuid, resources
8 , ... }:
9 let inherit (builtins.extraBuiltins) pass; in
10 {
11 # This value determines the NixOS release with which your system is to be
12 # compatible, in order to avoid breaking some software such as database servers.
13 # You should change this only after NixOS release notes say you should.
14 system.stateVersion = "19.09"; # Did you read the comment?
15
16 nixpkgs.overlays = import ../overlays.nix;
17
18 imports =
19 [ ../nixos/defaults.nix
20 mermet/apu2e4.nix
21 mermet/zfs.nix
22 mermet/lesptts.nix
23 mermet/shorewall.nix
24 mermet/unbound.nix
25 mermet/nsd.nix
26 mermet/openldap.nix
27 mermet/nginx.nix
28 #mermet/postfix.nix
29 #mermet/rspamd.nix
30 #mermet/dovecot2.nix
31 ];
32
33 networking = rec {
34 hostName = "mermet";
35 domainBase = "sourcephile";
36 domain = "${domainBase}.fr";
37 };
38
39 users = {
40 mutableUsers = false;
41 users = {
42 root = rec {
43 initialPassword = password;
44 password = pass "servers/mermet/login/root";
45 openssh.authorizedKeys.keys = [
46 (pass "members/julm/ssh.pub")
47 ];
48 };
49 };
50 groups = {
51 };
52 };
53
54 environment = {
55 systemPackages = with pkgs; [
56 cryptsetup
57 fio
58 git
59 gptfdisk
60 lm_sensors
61 smartctl-tbw
62 socat
63 ];
64 };
65 }