]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet/production/zfs.nix
losurdo: move everything from the SD card to the NVMe
[sourcephile-nix.git] / servers / mermet / production / zfs.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../base/zfs.nix
5 ];
6
7 # The 32-bit host id of the machine, formatted as 8 hexadecimal characters.
8 # You should try to make this id unique among your machines.
9 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
10 networking.hostId = "69c40b03";
11
12 /*
13 # Enable the (OpenSolaris-compatible) ZFS auto-snapshotting service.
14 services.zfs.autoSnapshot = {
15 enable = true;
16 frequent = ;
17 hourly = ;
18 daily = ;
19 weekly = ;
20 monthly = ;
21 };
22 */
23
24 /*
25 fileSystems."/boot" =
26 { device = "bpool/boot";
27 fsType = "zfs";
28 };
29 */
30 fileSystems."/" =
31 { device = "rpool/root";
32 fsType = "zfs";
33 };
34
35 fileSystems."/home" =
36 { device = "rpool/home";
37 fsType = "zfs";
38 };
39
40 fileSystems."/nix" =
41 { device = "rpool/nix";
42 fsType = "zfs";
43 };
44
45 fileSystems."/var" =
46 { device = "rpool/var";
47 fsType = "zfs";
48 };
49
50 fileSystems."/var/cache" =
51 { device = "rpool/var/cache";
52 fsType = "zfs";
53 };
54
55 fileSystems."/var/log" =
56 { device = "rpool/var/log";
57 fsType = "zfs";
58 };
59
60 fileSystems."/var/lib/dovecot" =
61 { device = "rpool/var/mail";
62 fsType = "zfs";
63 };
64
65 fileSystems."/var/lib/redis" =
66 { device = "rpool/var/redis";
67 fsType = "zfs";
68 };
69
70 fileSystems."/var/tmp" =
71 { device = "rpool/var/tmp";
72 fsType = "zfs";
73 };
74
75 fileSystems."/var/www" =
76 { device = "rpool/var/www";
77 fsType = "zfs";
78 };
79 }