1 {pkgs, lib, config, system, ...}:
2 let inherit (builtins) readFile;
3 inherit (builtins.extraBuiltins) pass;
5 inherit (pkgs.lib) loadFile;
6 inherit (config) networking;
7 inherit (config.services) nginx;
8 domainDir = dom: lib.concatStringsSep "/" (lib.reverseList (lib.splitString "." dom));
17 x509Dir = lib.mkOption {
19 default = "/var/lib/nginx/x509";
21 webDir = lib.mkOption {
25 logDir = lib.mkOption {
27 default = "/var/log/nginx";
33 "nginx.${networking.domainBase}.key.pem" = {
34 text = pass "x509/${networking.domainBase}/key.pem";
37 destDir = "/run/keys/";
38 permissions = "0400"; # WARNING: not enforced when deployment.storeKeysOnMachine = true
41 systemd.services.nginx = {
42 preStart = lib.mkBefore ''
43 install -D -d -o ${nginx.user} -g ${nginx.group} -m 0700 \
49 "nginx.${networking.domainBase}.key.pem-key.service"
54 stateDir = "/dev/shm/nginx";
58 worker_connections 1024;
60 clientMaxBodySize = "20m";
61 recommendedProxySettings = true;
62 recommendedTlsSettings = true;
64 # Only allow PFS-enabled ciphers with AES256
65 sslCiphers = "AES256+EECDH:AES256+EDH:!aNULL";
66 #sslCiphers = "HIGH:!ADH:!MD5:!CAMELLIA:!SEED:!3DES:!DES:!RC4:!eNULL";
67 sslDhparam = ../../../sec/openssl/dh.pem;
68 #sslCiphers = "EECDH+aRSA+AESGCM:EDH+aRSA:EECDH+aRSA:+AES256:+AES128:+SHA1:!CAMELLIA:!SEED:!3DES:!DES:!RC4:!eNULL;";
69 #sslProtocols = "TLSv1.2";
71 log_format main '$remote_addr - $remote_user [$time_local] "$request" '
72 '$status $body_bytes_sent "$http_referer" '
73 '"$http_user_agent" "$http_x_forwarded_for"';
76 lib.concatStringsSep "\n" (lib.attrValues {
78 default_type application/octet-stream;
82 #error_page 403 = 404;
84 # Add HSTS header with preloading to HTTPS requests.
85 # Adding this header to HTTP requests is discouraged
86 #map $scheme $hsts_header {
87 # https "max-age=31536000; includeSubdomains; preload";
89 #add_header Strict-Transport-Security $hsts_header;
91 # Enable CSP for your services.
92 #add_header Content-Security-Policy "script-src 'self'; object-src 'none'; base-uri 'none';" always;
94 # Minimize information leaked to other domains
95 add_header 'Referrer-Policy' 'origin-when-cross-origin';
97 # Disable embedding as a frame
98 add_header X-Frame-Options DENY;
100 # Prevent injection of code in other mime types (XSS Attacks)
101 add_header X-Content-Type-Options nosniff;
103 # Enable XSS protection of the browser.
104 # May be unnecessary when CSP is configured properly (see above)
105 add_header X-XSS-Protection "1; mode=block";
107 # This might create errors
108 proxy_cookie_path / "/; secure; HttpOnly; SameSite=strict";
111 access_log ${nginx.logDir}/access.log main buffer=32k;
112 error_log ${nginx.logDir}/error.log warn;
113 open_log_file_cache max=1000 inactive=20s min_uses=2 valid=1m;
116 proxy_cache_use_stale updating;
117 proxy_temp_path ${nginx.stateDir}/proxy_temp 1 2;
120 # DOC: http://wiki.nginx.org/HttpFastcgiModule
121 fastcgi_buffer_size 128k;
122 fastcgi_buffers 256 4k;
123 fastcgi_busy_buffers_size 256k;
124 fastcgi_cache_key "$request_method $scheme://$http_host$request_uri";
125 fastcgi_cache_path ${nginx.stateDir}/fastcgi_cache
127 keys_zone=microcache:2M
131 loader_threshold=2592000000
133 fastcgi_connect_timeout 60;
134 fastcgi_ignore_client_abort off;
135 fastcgi_intercept_errors on;
136 fastcgi_max_temp_file_size 2M;
137 #fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
138 fastcgi_param SCRIPT_FILENAME $request_filename;
139 fastcgi_temp_path ${nginx.stateDir}/fastcgi_temp 1 2;
143 # If the client stops reading data,
144 # free up the stale client connection after this much time.
146 # Causes nginx to attempt to send its HTTP response head
147 # in one packet, instead of using partial frames.
148 # This is useful for prepending headers before calling sendfile,
149 # or for throughput optimization.
151 # Don't buffer data-sends (disable Nagle algorithm).
152 # Good for sending frequent small bursts of data in real time.
154 keepalive_timeout 20;
155 reset_timedout_connection on;
156 server_names_hash_bucket_size 128;
157 types_hash_max_size 2048;
160 # User agents that are to be blocked.
161 #map $http_user_agent $bad_bot {
164 # ~(?i)(httrack|htmlparser|libwww) 1;
166 # Referrers that are to be blocked.
167 #map $http_referer $bad_referer {
169 # ~(?i)(babes|casino|click|diamond|forsale|girl|jewelry|love|nudit|organic|poker|porn|poweroversoftware|replica|sex|teen|webcam|zippo) 1;
180 gzip_disable "MSIE [1-6]\.";
181 gzip_http_version 1.1;
182 gzip_min_length 1024;
186 gzip_types application/atom+xml
187 application/javascript
190 application/vnd.ms-fontobject
191 application/x-font-ttf
192 application/x-javascript
205 client_body_buffer_size 4K;
208 client_body_temp_path ${nginx.stateDir}/client_body_temp 1 2;
209 client_body_timeout 60;
210 client_header_buffer_size 1k;
211 client_header_timeout 60;
212 large_client_header_buffers 4 8k;
214 open_file_cache max=200000 inactive=20s;
215 open_file_cache_errors on;
216 open_file_cache_min_uses 2;
217 open_file_cache_valid 30s;
225 # Convoluted way to load the certificate in the store and using ${networking.domainBase} to find it.
226 # NOTE: no ssl_stapling while the certificate remains self-signed.
227 sslCertificate = loadFile (../../../sec + "/openssl/${networking.domainBase}/cert.self-signed.pem");
228 sslCertificateKey = "/run/keys/nginx.${networking.domainBase}.key.pem";