1 { pkgs, lib, config, ... }:
4 inherit (builtins.extraBuiltins) pass git;
5 inherit (pkgs.lib) unlinesAttrs;
6 inherit (config) networking;
7 inherit (config.services) nsd rspamd;
8 # Use the Git commit time of the ${zone}.nix file to set the serial number.
9 # WARNING: the ${zone}.nix must be committed into Git for this to work.
10 serial = zone: toString (git ./. [ "log" "-1" "--format=%ct" "--" (zone + ".nix") ]);
12 serial = file: lib.removeSuffix "\n" (readFile
13 (pkgs.runCommand "zone-serial"
14 { buildInputs = [ pkgs.git ];
15 buildDepends = [ (./. + file) ];
16 preferLocalBuild = true;
17 allowSubstitutes = false;
20 ${pkgs.git}/bin/git log -1 --format="%ct" -- ${file} >$out
23 # FIXME: make dedicated config options
24 #ipv4 = (elemAt networking.interfaces.enp1s0.ipv4.addresses 0).address;
25 ipv4 = "80.67.180.129";
26 #ipv6 = (elemAt networking.interfaces.enp1s0.ipv6.addresses 0).address;
27 sourcephileZone = domain: ''
30 ${networking.hostName} A ${ipv4}
42 ; SPF (Sender Policy Framework)
43 @ 3600 IN SPF "v=spf1 mx ip4:${ipv4} -all"
44 @ 3600 IN TXT "v=spf1 mx ip4:${ipv4} -all"
50 _git._tcp.git 18000 IN SRV 0 0 9418 git
54 + lib.optionalString rspamd.dkim.enable
56 (selector: sel: sel.dns)
57 rspamd.dkim.domains."${domain}".selectors)
61 environment.systemPackages = [
62 (pkgs.bind.override { enablePython = true; })
66 # NOTE: cannot use networking.domain as attr key: infinite recursion.
68 # DOC: https://docs.gandi.net/en/domain_names/advanced_users/secondary_nameserver.html
69 # DOC: https://www.sidn.nl/en/dnssec/dnssec-signatures-in-bind-named
70 provideXFR = [ "217.70.177.40 NOKEY" ];
71 notify = [ "217.70.177.40 NOKEY" ];
74 $ORIGIN ${networking.domainBase}.fr.
77 ; SOA (Start Of Authority)
79 ${serial networking.domainBase} ; Serial number
82 1000h ; Expire (1000h)
90 + sourcephileZone "${networking.domainBase}.fr";