]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/networking/nftables.nix
upnpc: use DHCP and UPnP on losurdo
[sourcephile-nix.git] / machines / losurdo / networking / nftables.nix
1 { pkgs, lib, config, machines, ... }:
2 let
3 inherit (builtins) hasAttr readFile;
4 inherit (pkgs.lib) unlinesAttrs;
5 inherit (config) networking;
6 inherit (config.users) users groups;
7 in
8 {
9 networking.firewall.enable = false;
10 security.lockKernelModules = false;
11 systemd.services.disable-kernel-module-loading.after = [ "nftables.service" ];
12 systemd.services.nftables.serviceConfig.TimeoutStartSec = "20";
13 networking.nftables = {
14 enable = true;
15 ruleset = lib.mkBefore ''
16 table inet filter {
17 # A set containing the udp port(s) to which SSDP replies are allowed.
18 set ssdp_out {
19 type inet_service
20 timeout 5s
21 }
22 set lograte4 { type ipv4_addr; size 65535; flags dynamic; }
23 set lograte6 { type ipv6_addr; size 65535; flags dynamic; }
24 chain block {
25 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "block: "
26 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "block: "
27 counter drop
28 }
29 chain ping-flood {
30 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "ping-flood: "
31 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "ping-flood: "
32 counter drop
33 }
34 chain smurf {
35 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "smurf: "
36 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "smurf: "
37 counter drop
38 }
39 chain bogus-tcp {
40 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "bogus-tcp: "
41 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "bogus-tcp: "
42 counter drop
43 }
44 chain syn-flood {
45 add @lograte4 { ip saddr limit rate 1/minute } log level warn prefix "syn-flood: "
46 add @lograte6 { ip6 saddr limit rate 1/minute } log level warn prefix "syn-flood: "
47 counter drop
48 }
49 chain check-tcp {
50 tcp flags syn tcp option maxseg size != 536-65535 counter goto bogus-tcp
51 tcp flags & (ack|fin) == fin counter goto bogus-tcp
52 tcp flags & (ack|psh) == psh counter goto bogus-tcp
53 tcp flags & (ack|urg) == urg counter goto bogus-tcp
54 tcp flags & (fin|ack) == fin counter goto bogus-tcp
55 tcp flags & (fin|rst) == (fin|rst) counter goto bogus-tcp
56 tcp flags & (fin|psh|ack) == (fin|psh) counter goto bogus-tcp
57 tcp flags & (syn|fin) == (syn|fin) counter goto bogus-tcp comment "SYN-FIN scan"
58 tcp flags & (syn|rst) == (syn|rst) counter goto bogus-tcp comment "SYN-RST scan"
59 tcp flags == (fin|syn|rst|psh|ack|urg) counter goto bogus-tcp comment "XMAS scan"
60 tcp flags == 0x0 counter goto bogus-tcp comment "NULL scan"
61 tcp flags == (fin|urg|psh) counter goto bogus-tcp
62 tcp flags == (fin|urg|psh|syn) counter goto bogus-tcp comment "NMAP-ID"
63 tcp flags == (fin|urg|syn|rst|ack) counter goto bogus-tcp
64
65 ct state new tcp flags != syn counter goto bogus-tcp
66 tcp sport 0 tcp flags & (fin|syn|rst|ack) == syn counter goto bogus-tcp
67 tcp flags & (fin|syn|rst|ack) == syn counter limit rate over 30/second burst 60 packets goto syn-flood
68 }
69 chain net2fw {
70 #udp dport mdns ip6 daddr ff02::fb counter accept comment "Accept mDNS"
71 #udp dport mdns ip daddr 224.0.0.251 counter accept comment "Accept mDNS"
72 #jump non-internet
73
74 #ct state new add @connlimit { ip saddr ct count over 20 } counter tcp reject with tcp reset
75
76 # Some .nix append rules here with: add rule inet filter net2fw ...
77 }
78 chain fw2net {
79 tcp dport { 80, 443 } counter accept comment "HTTP"
80 udp dport 123 skuid ${users.systemd-timesync.name} counter accept comment "NTP"
81 tcp dport 9418 counter accept comment "Git"
82
83 # Some .nix append rules here with: add rule inet filter fw2net ...
84 }
85 chain intra2fw {
86 # Some .nix append rules here with: add rule inet filter intra2fw ...
87 }
88 chain fw2intra {
89 # Some .nix append rules here with: add rule inet filter fw2intra ...
90 }
91 chain fwd-intra {
92 # Some .nix append rules here with: add rule inet filter fwd-intra ...
93 }
94 chain extra2fw {
95 # Some .nix append rules here with: add rule inet filter extra2fw ...
96 }
97 chain accept-icmpv6 {
98 # Traffic That Must Not Be Dropped
99 # https://tools.ietf.org/html/rfc4890#section-4.4.1
100 icmpv6 type destination-unreachable counter accept
101 icmpv6 type packet-too-big counter accept
102 icmpv6 type time-exceeded counter accept
103 icmpv6 type parameter-problem counter accept
104
105 # Address Configuration and Router Selection messages
106 # (must be received with hop limit = 255)
107 icmpv6 type nd-router-solicit ip6 hoplimit 255 counter accept
108 ip6 nexthdr ipv6-icmp icmpv6 type nd-router-advert ip6 hoplimit 255 counter accept
109 icmpv6 type nd-neighbor-solicit ip6 hoplimit 255 counter accept
110 icmpv6 type nd-neighbor-advert ip6 hoplimit 255 counter accept
111 icmpv6 type nd-redirect ip6 hoplimit 255 log level warn prefix "icmpv6: nd-redirect: " counter drop
112 icmpv6 type ind-neighbor-solicit ip6 hoplimit 255 counter accept
113 icmpv6 type ind-neighbor-advert ip6 hoplimit 255 counter accept
114
115 # Link-local multicast receiver notification messages
116 # (must have link-local source address)
117 icmpv6 type mld-listener-query ip6 saddr fe80::/10 counter accept
118 icmpv6 type mld-listener-report ip6 saddr fe80::/10 counter accept
119 icmpv6 type mld-listener-done ip6 saddr fe80::/10 counter accept
120 # https://tools.ietf.org/html/rfc3810 Multicast Listener Discovery Version 2 (MLDv2) for IPv6
121 icmpv6 type mld2-listener-report ip6 saddr fe80::/10 counter accept
122
123 # SEND Certificate Path notification messages
124 # (must be received with hop limit = 255)
125 icmpv6 type 148 ip6 hoplimit 255 counter accept comment "certificate-path-solicitation"
126 icmpv6 type 149 ip6 hoplimit 255 counter accept comment "certificate-path-advertisement"
127
128 # Multicast Router Discovery messages
129 # (must have link-local source address and hop limit = 1)
130 icmpv6 type 151 ip6 saddr fe80::/10 ip6 hoplimit 1 counter accept comment "multicast-router-advertisement"
131 icmpv6 type 152 ip6 saddr fe80::/10 ip6 hoplimit 1 counter accept comment "multicast-router-solicitation"
132 icmpv6 type 153 ip6 saddr fe80::/10 ip6 hoplimit 1 counter accept comment "multicast-router-termination"
133 }
134
135 chain input {
136 type filter hook input priority filter
137 policy drop
138
139 iifname lo accept
140
141 jump check-tcp
142
143 ct state { established, related } accept
144
145 # Connectivity checking messages
146 # (multicast) ping
147 ip protocol icmp icmp type echo-reply counter accept
148
149 ${lib.optionalString networking.enableIPv6 ''
150 # drop packets with rh0 headers
151 rt type 0 jump block
152 rt type 0 jump block
153 rt type 0 jump block
154
155 # (multicast) ping
156 ip6 nexthdr ipv6-icmp icmpv6 type echo-reply counter accept
157
158 #ip6 daddr fe80::/64 udp dport 546 counter accept comment "DHCPv6"
159 ''}
160
161 ct state invalid counter drop
162
163 ip protocol icmp icmp type destination-unreachable counter accept
164 ip protocol icmp icmp type time-exceeded counter accept
165 ip protocol icmp icmp type parameter-problem counter accept
166 ip protocol icmp icmp type echo-request limit rate over 10/second burst 20 packets goto ping-flood
167 ip protocol icmp icmp type echo-request counter accept
168 # echo-reply is handled before invalid packets to allow multicast ping
169 # which do not have an associated connection.
170
171 #ip daddr 224.0.0.251 udp dport 5353 counter accept comment "mDNS"
172 #ip saddr 0.0.0.0/32 counter accept comment "DHCP"
173 #ip udp sport 67 udp dport 68 counter accept comment "DHCP"
174
175 ${lib.optionalString networking.enableIPv6 ''
176 ip6 nexthdr ipv6-icmp jump accept-icmpv6
177
178 # Connectivity checking messages
179 icmpv6 type echo-request counter accept
180 # echo-reply is handled before invalid because of multicast
181
182 ip6 nexthdr ipv6-icmp log level err prefix "net2fw: icmpv6: catch all: " counter reject
183
184 ip6 daddr ff02::fb udp dport 5353 counter accept comment "mDNS"
185 ''}
186
187 ip saddr 224.0.0.0/4 counter goto smurf
188 fib saddr type broadcast counter goto smurf
189
190 # admin services
191 tcp dport 22 counter accept comment "SSH"
192 udp dport 60000-61000 counter accept comment "Mosh"
193
194 # Some .nix append gotos here with: add rule inet filter input iffname ... goto ...
195 }
196 chain forward {
197 type filter hook forward priority filter
198 policy drop
199
200 ct state { related, established } accept
201
202 ip protocol icmp icmp type destination-unreachable counter accept
203 ip protocol icmp icmp type time-exceeded counter accept
204 ip protocol icmp icmp type parameter-problem counter accept
205 ip protocol icmp icmp type echo-request counter accept
206
207 ${lib.optionalString networking.enableIPv6 ''
208 # Traffic That Must Not Be Dropped
209 # https://tools.ietf.org/html/rfc4890#section-4.3.1
210 ip6 nexthdr ipv6-icmp icmpv6 type destination-unreachable counter accept
211 ip6 nexthdr ipv6-icmp icmpv6 type packet-too-big counter accept
212 ip6 nexthdr ipv6-icmp icmpv6 type time-exceeded counter accept
213 ip6 nexthdr ipv6-icmp icmpv6 type parameter-problem counter accept
214
215 # Connectivity checking messages
216 ip6 nexthdr ipv6-icmp icmpv6 type echo-request counter accept
217 ip6 nexthdr ipv6-icmp icmpv6 type echo-reply counter accept
218
219 # Traffic That Normally Should Not Be Dropped
220 # https://tools.ietf.org/html/rfc4890#section-4.3.2
221 ip6 nexthdr ipv6-icmp icmpv6 type 144 counter accept comment "home-agent-address-discovery-request"
222 ip6 nexthdr ipv6-icmp icmpv6 type 145 counter accept comment "home-agent-address-discovery-reply"
223 ip6 nexthdr ipv6-icmp icmpv6 type 146 counter accept comment "mobile-prefix-solicitation"
224 ip6 nexthdr ipv6-icmp icmpv6 type 147 counter accept comment "mobile-prefix-advertisement"
225 ''}
226 }
227 chain output {
228 type filter hook output priority filter
229 policy drop
230
231 oifname lo accept
232
233 ct state { related, established } accept
234
235 ip protocol icmp counter accept
236 meta skuid 0 udp dport 33434-33523 counter accept comment "traceroute"
237
238 ${lib.optionalString networking.enableIPv6 ''
239 ip6 nexthdr ipv6-icmp jump accept-icmpv6
240
241 # Connectivity checking messages
242 ip6 nexthdr ipv6-icmp icmpv6 type echo-request counter accept
243 ip6 nexthdr ipv6-icmp icmpv6 type echo-reply counter accept
244 ip6 nexthdr ipv6-icmp log level err prefix "fw2net: icmpv6: catch all: " counter reject
245
246 ip6 daddr ff02::1:2/64 udp dport 547 counter accept comment "DHCPv6"
247 ''}
248
249 ct state invalid log level warn prefix "fw2net: invalid: " counter drop
250
251 tcp dport 22 counter accept comment "SSH"
252
253 # Some .nix append gotos here with: add rule inet filter output oifname ... goto ...
254 }
255 }
256 table inet nat {
257 chain prerouting {
258 type nat hook prerouting priority filter
259 policy accept
260 }
261 chain postrouting {
262 type nat hook postrouting priority srcnat
263 policy accept
264 }
265 }
266 '';
267 };
268 }