]> Git — Sourcephile - sourcephile-nix.git/blob - install/logical/friot/nsd/sourcephile.nix
nixops: add mermet
[sourcephile-nix.git] / install / logical / friot / nsd / sourcephile.nix
1 {pkgs, lib, config, ...}:
2 let inherit (builtins) toString toPath readFile;
3 inherit (builtins.extraBuiltins) pass;
4 inherit (pkgs.lib) unlinesAttrs;
5 inherit (config) networking;
6 inherit (config.services) nsd dkim;
7 serial = zone: toString (builtins.extraBuiltins.git ./. [ "log" "-1" "--format=%ct" "--" (zone + ".nix") ]);
8 /*
9 serial = file: lib.removeSuffix "\n" (readFile
10 (pkgs.runCommand "zone-serial"
11 { buildInputs = [ pkgs.git ];
12 buildDepends = [ (toPath ./. + file) ];
13 preferLocalBuild = true;
14 allowSubstitutes = false;
15 } ''
16 cd ${toPath ./.}
17 ${pkgs.git}/bin/git log -1 --format="%ct" -- ${file} >$out
18 ''));
19 */
20 ipv4 = networking.zones.net.ipv4;
21 sourcephileZone = domain: ''
22 ; A (DNS -> IPv4)
23 @ A ${ipv4}
24 autoconfig A ${ipv4}
25 git A ${ipv4}
26 imap A ${ipv4}
27 mail A ${ipv4}
28 ns A ${ipv4}
29 pop A ${ipv4}
30 redmine A ${ipv4}
31 smtp A ${ipv4}
32 submission A ${ipv4}
33 www A ${ipv4}
34
35 ; SPF (Sender Policy Framework)
36 @ 3600 IN SPF "v=spf1 mx ip4:${ipv4} -all"
37 @ 3600 IN TXT "v=spf1 mx ip4:${ipv4} -all"
38
39 ; MX (Mail eXchange)
40 @ 180 MX 5 mail
41
42 ; SRV (SeRVice)
43 _git._tcp.git 18000 IN SRV 0 0 9418 git
44
45 ; TXT (TeXT)
46 ''
47 + unlinesAttrs
48 (selector: sel: sel.dns)
49 dkim.domains."${domain}".selectors;
50 in
51 {
52 config = {
53 services.dkim.domains =
54 let domain = rec {
55 selector = "2020010101";
56 selectors = {
57 "2020010101" = {
58 key = pass "${networking.domainBase}/dkim/2020010101/key" + "\n";
59 dns = ''
60 2020010101._domainkey IN TXT ( "v=DKIM1; k=rsa; "
61 "p=MIICIjANBgkqhkiG9w0BAQEFAAOCAg8AMIICCgKCAgEA7EKzverbG+5JF+yFjH3MrxLyauiHyLqBbV/8LEMunoKXF8sqhBpQtAQXruLqsyUkxR/4CAyPMyzmcdrU43boMj9yFqLrg/kEz2RIvai9jXBqRoWRW1y7F0LbZmdtOTncuDSP8Zzo02XUzsOC4f/C3tEQHS5rchzfhU5FY1CeO6eBMV79qKBOvGMKahQTrrtU6olAAJxOhn6wRuwSf"
62 "+m3on1OqiuXYYIgNHKdRhJ8gDwIm/3LEpYMD0gTgJiyclCLoLGHGtKZy1Wf9xV9/7V6fHE4JW5SDivwslVTL+KPXOlIpo5NDHpMxPYOcIg2K4Rj/j7jhavo+fG43q1LhwaPkEMQMbplgnjeMY8300odRiklTkMMpH0m35ZNeHQJSRpEtV8y5xUNxVaGzfqX5iStwV/mQ1KnZSe8ORTNq+eTTFnDk6zdUXjagcf0wO6QsSTeAz/G8CqOBbwmrU+q"
63 "F8WbGAeRnhz51mH6fTTfsQ1nwjAiF4ou+eQGTkTMN23KkCKpuozJnxqx4DCEr6J1bL83fhXw7CgcfgKgTOk/HFJpeiGhqodw18r4DWBA6G57z9utm7Mr/9SoVnMq6iK9iEcbCllLR8Sz4viatLSRzhodbk7hfvXS3jmCFjILAjFmA7aMTemDMBDQhpAGF9F8sjFUbEJIZjKrWWtSTdO8DilDqN8CAwEAAQ=="
64 ) ;
65 '';
66 };
67 };
68 }; in
69 {
70 "${networking.domainBase}.fr" = domain;
71 };
72 services.nsd = {
73 zones = {
74 # NOTE: cannot use networking.domain as attr key: infinite recursion
75 "sourcephile.fr" = {
76 data = ''
77 $ORIGIN ${networking.domainBase}.fr.
78 $TTL 86400
79
80 ; SOA (Start Of Authority)
81 @ SOA ns admin (
82 ${serial networking.domainBase} ; Serial number
83 1d ; Refresh
84 15m ; Retry
85 2592000 ; Expire
86 1d ; TTL (Time To Live) minimum
87 )
88
89 ; NS (Name Server)
90 @ NS ns
91 ;@ NS ns6.gandi.net.
92 ''
93 + sourcephileZone "${networking.domainBase}.fr";
94 };
95 };
96 };
97 };
98 }