]> Git — Sourcephile - sourcephile-nix.git/blob - install/options.nix
nixops: add mermet
[sourcephile-nix.git] / install / options.nix
1 {pkgs, lib, config, system, ...}: {
2 options = {
3 enable = lib.mkEnableOption "friot";
4 networking.domainBase = lib.mkOption {
5 type = types.str;
6 description = "Base network name.";
7 example = "example";
8 };
9 networking.domainAliases = lib.mkOption {
10 type = types.listOf types.str;
11 description = "Domain aliases.";
12 example = [ "example.org" "example.net" ];
13 };
14 networking.zones = lib.mkOption {
15 type = types.attrsOf (types.submodule ({name, options, config, ...}: {
16 options = {
17 iface = lib.mkOption {
18 type = types.str;
19 description = "Interface name.";
20 example = "eth0";
21 };
22 ipv4 = lib.mkOption {
23 type = types.str;
24 description = "Static IPv4 address of the machine.";
25 example = "1.2.3.4";
26 };
27 ipv6 = lib.mkOption {
28 type = types.str;
29 description = "Static IPv6 address of the machine.";
30 example = "fe80::1";
31 };
32 };
33 }));
34 };
35 };
36 }