]> Git — Sourcephile - sourcephile-nix.git/blob - install/physical/production.nix
nixops: add mermet
[sourcephile-nix.git] / install / physical / production.nix
1 # Sourcephile physical network
2 {
3 /*
4 friot = {pkgs, lib, config, ...}: {
5 deployment.targetHost = "1.2.3.4";
6 deployment.autoLuks = {
7 # NOTE: not working on virtualbox deployment
8 secretdisk = {
9 device = "/dev/sda";
10 passphrase = "foobar";
11 autoFormat = true;
12 cipher = "aes-cbc-essiv:sha256";
13 };
14 };
15 networking.zones = {
16 net = {
17 iface = null;
18 ipv4 = null;
19 };
20 lan = {
21 iface = null;
22 ipv4 = null;
23 };
24 };
25 };
26 */
27 mermet = {pkgs, lib, config, ...}: {
28 deployment.targetHost = "mermet.sourcephile.fr";
29 };
30 }