]> Git — Sourcephile - sourcephile-nix.git/blob - nixos/modules/services/networking/domains.nix
mermet: fix the networking
[sourcephile-nix.git] / nixos / modules / services / networking / domains.nix
1 {pkgs, lib, config, system, ...}:
2 let inherit (lib) types;
3 in {
4 options.networking = {
5 domainBase = lib.mkOption {
6 type = types.str;
7 description = "Base network name.";
8 example = "example";
9 };
10 domainAliases = lib.mkOption {
11 type = types.listOf types.str;
12 description = "Domain aliases.";
13 default = [];
14 example = [ "example.org" "example.net" ];
15 };
16 };
17 }