1 { pkgs, lib, config, inputs, ... }:
3 inherit (config.boot) initrd;
5 wg = config.networking.wireguard.interfaces.${wgIface};
6 wg-intra-peers = import (inputs.julm-nix + "/nixos/profiles/wireguard/wg-intra/peers.nix");
7 relay = wg-intra-peers.mermet;
11 (inputs.julm-nix + "/nixos/profiles/wireguard/wg-intra.nix")
13 systemd.services."wireguard-${wgIface}" = {
15 LoadCredentialEncrypted = [ "privateKey:${./. + "/${wgIface}/privateKey.cred"}" ];
18 Upholds = [ "upnpc-${toString wg.listenPort}.service" ];
21 networking.wireguard.${wgIface}.peers = {
25 carotte.enable = true;
26 aubergine.enable = true;
28 networking.nftables.ruleset = ''
31 tcp dport ssh counter accept comment "SSH"
32 udp dport 60000-61000 counter accept comment "Mosh"
35 tcp dport { ssh, 2222 } counter accept comment "SSH"
36 udp dport 60001-60010 counter accept comment "Mosh"
37 tcp dport { http, https } counter accept comment "HTTP"
38 tcp dport git counter accept comment "Git"
43 iifname ${wgIface} oifname netIface masquerade
47 # Apparently required to get NAT reflection.
48 services.upnpc.enable = true;
49 services.upnpc.redirections = [
51 description = "WireGuard";
52 externalPort = wg.listenPort;
55 service.requiredBy = [ "wireguard-${wgIface}.service" ];
56 service.before = [ "wireguard-${wgIface}.service" ];
59 boot.kernel.sysctl."net.ipv4.ip_forward" = 1;
61 # Open a wireguard tunnel to a relay
62 # in case the host is hosted behind a NAT and has no SSH port forwarding.
63 # This enables to send the disk password to the initrd, like that:
64 # ssh -J mermet.sourcephile.fr root@losurdo.wg -p 2222
65 # TODO: use a dedicated interface wg-initrd
66 boot.initrd.secrets."/root/initrd/${wgIface}.key" = "/run/credentials/wireguard-${wgIface}.service/privateKey";
67 boot.initrd.kernelModules = [ "wireguard" ];
68 boot.initrd.extraUtilsCommands = ''
69 #copy_bin_and_libs ${pkgs.wireguard-tools}/bin/wg
70 cp -fpdv ${pkgs.wireguard-tools}/bin/.wg-wrapped $out/bin/wg
72 boot.initrd.network.postCommands = ''
73 ip link add dev ${wgIface} type wireguard
74 ${lib.concatMapStringsSep "\n" (ip: ''
75 ip address add ${ip} dev ${wgIface}
77 wg set ${wgIface} private-key /root/initrd/${wgIface}.key \
78 listen-port ${toString wg.listenPort}
79 ip link set up dev ${wgIface} mtu 1280
80 wg set ${wgIface} peer ${relay.peer.publicKey} \
81 endpoint ${relay.ipv4}:${toString relay.listenPort} \
82 allowed-ips ${relay.ipv4}/32 \
83 persistent-keepalive 5
84 ip route replace ${relay.ipv4}/32 dev ${wgIface} table main
86 boot.initrd.postMountCommands = lib.mkIf initrd.network.flushBeforeStage2 ''
87 ip link del dev ${wgIface}