1 { pkgs, lib, config, system, ... }:
3 inherit (builtins) toString toFile readFile;
4 inherit (builtins.extraBuiltins) pass;
6 inherit (pkgs.lib) loadFile unlines unlinesAttrs unlinesValues unwords;
7 inherit (config) networking;
8 inherit (config.services) dovecot2 postfix openldap;
10 # NOTE: nixpkgs' dovecot2.stateDir is currently not exported
11 stateDir = "/var/lib/dovecot";
13 sieve_pipe_bin_dir = pkgs.buildEnv {
14 name = "sieve_pipe_bin_dir";
15 pathsToLink = [ "/bin" ];
21 learn-spam = pkgs.writeShellScriptBin "learn-spam.sh" ''
22 exec ${pkgs.rspamd}/bin/rspamc -h /run/rspamd/learner.sock learn_spam
24 learn-ham = pkgs.writeShellScriptBin "learn-ham.sh" ''
25 exec ${pkgs.rspamd}/bin/rspamc -h /run/rspamd/learner.sock learn_ham
28 dovecot-virtual = pkgs.buildEnv {
29 name = "dovecot-virtual";
30 pathsToLink = [ "/" ];
33 dovecot-virtual-recents
36 dovecot-virtual-all = pkgs.writeTextFile {
37 name = "dovecot-virtual-all";
38 destination = "/All/dovecot-virtual";
44 dovecot-virtual-recents = pkgs.writeTextFile {
45 name = "dovecot-virtual-recents";
46 destination = "/Recents/dovecot-virtual";
52 dovecot-virtual-pop3 = pkgs.writeTextFile {
53 name = "dovecot-virtual-pop3";
54 destination = "/pop3/INBOX/dovecot-virtual";
64 dovecot/sourcephile.fr.nix
65 dovecot/autogeree.net.nix
67 systemd.services.dovecot2 = {
74 # SEE: http://wiki2.dovecot.org/SharedMailboxes/Permissions
75 install -D -d -m 0771 \
76 -o "${dovecot2.user}" \
77 -g "${dovecot2.group}" \
82 #users.users."${dovecot2.mailUser}".isSystemUser = true; # Fix nixpkgs
86 pkgs.dovecot_pigeonhole
87 pkgs.dovecot_fts_xapian
93 protocols = [ "sieve" ];
94 # If needed, may be overrided by userdb_mail= in passdb, or mail= in userdb
95 # Here INDEX and CONTROL are separated,
96 # it's not useful since there is not quota at the filesystem level
97 # it's just to let this possibility later on.
98 mailLocation = "sdbox:${stateDir}/home/%d/%n/mail:UTF-8:CONTROL=${stateDir}/control/%d/%n:INDEX=${stateDir}/index/%d/%n";
99 createMailUser = false;
102 sslServerCert = null;
104 global = dovecot/sieve/global;
111 log_timestamp = "%Y-%m-%d %H:%M:%S "
114 ssl_dh = <${../../../sec/openssl/dh.pem}
115 ssl_cipher_list = HIGH:!LOW:!SSLv2:!EXP:!aNULL
116 ssl_prefer_server_ciphers = yes
117 ssl_cert = </var/lib/acme/${networking.domain}/fullchain.pem
118 ssl_key = </var/lib/acme/${networking.domain}/key.pem
119 #ssl_ca = <''${caPath}
120 #ssl_verify_client_cert = yes
123 # If needed, may be overrided by userdb_mail
124 mail_home = ${stateDir}/home/%d/%n
125 # Read multiple mails in parallel, improves performance
126 mail_prefetch_count = 20
127 # Default VSZ (virtual memory size) limit for service processes. This is mainly
128 # intended to catch and kill processes that leak memory before they eat up everything.
129 # Increased for fts_xapian.
130 default_vsz_limit = 1G
132 # DOC: https://doc.dovecot.org/configuration_manual/authentication/authentication_mechanisms/
133 # DOC: https://ldapwiki.com/wiki/DIGEST-MD5
134 # The misunderstanding is the notion "password sent over the network in plain-text" is not secure,
135 # when in fact, storing the password in the directory server using a Salted SHA-2 hash
136 # and transmitting the clear text password over a secure connection
137 # is more secure than having the directory server store the password in clear text
138 # or in a reversible encryption scheme.
139 # Therefore, SASL with DIGEST-MD5 (or CRAM-MD5) should be avoided.
140 # Use doveadm pw -s SSHA
141 # or doveadm pw -s PBKDF2 -r 10000
142 # or slappasswd -o module-load=pw-pbkdf2 -h "{PBKDF2-SHA256}"
143 auth_mechanisms = plain login
144 auth_username_format = %Ln
146 user = ${dovecot2.user}
147 # auth_socket_path points to this userdb socket by default. It's typically
148 # used by dovecot-lda, doveadm, possibly imap process, etc.
149 # Users that have access to this socket are able to get a list
150 # of all usernames and get results of everyone's userdb lookups.
151 unix_listener auth-userdb {
152 user = ${dovecot2.user}
153 group = ${dovecot2.group}
156 unix_listener /var/lib/postfix/queue/private/auth {
157 user = ${postfix.user}
158 group = ${postfix.group}
162 service auth-worker {
163 user = ${dovecot2.user}
165 auth_cache_verify_password_with_worker = yes
166 # SEE: http://wiki2.dovecot.org/Quota/FS
167 # NOTE: postfix does not supply a client cert.
168 auth_ssl_require_client_cert = no
169 #auth_ssl_username_from_cert = yes
170 # NOTE: lowercase the username, help with LDAP?
171 auth_username_format = %Lu
172 # NOTE: sync with LDAP's data.
173 first_valid_uid = 1000
174 disable_plaintext_auth = yes
178 # A different path than passdb's args enables non-blocking LDAP requests
179 args = ${pkgs.symlinkJoin {name="ldap"; paths=[./dovecot];}}/ldap.conf
184 # No dirty syncs for maildir: locations which may be used directly by neomutt
185 maildir_very_dirty_syncs = no
197 # NOTE: always listed in the LIST command.
199 # NOTE: how to access the other users' mailboxes.
200 # NOTE: %var expands to the logged in user's variable, while
201 # %%var expands to the other users' variables.
202 # NOTE: INDEX and CONTROL are shared, INDEXPVT is not.
203 location = sdbox:${stateDir}/home/%%d/%%n/${stateDir}/mail:UTF-8:CONTROL=${stateDir}/control/%%d/%%n/shared:INDEX=${stateDir}/index/%%d/%%n/shared:INDEXPVT=${stateDir}/index/%d/%n/shared/%%n
204 prefix = Partages+%%n+
208 mail_plugins = $mail_plugins virtual
215 location = virtual:${dovecot-virtual}:UTF-8:INDEX=${stateDir}/index/%d/%n/virtual
218 mail_plugins = $mail_plugins acl
220 acl = vfile:/etc/dovecot/acl/global
222 # NOTE: to let users LIST mailboxes shared by other users,
223 # Dovecot needs a shared mailbox dictionary.
224 # FIXME: %d not working with userdb ldap
225 acl_shared_dict = file:${stateDir}/acl/%d/acl.db
228 mail_plugins = $mail_plugins fts fts_xapian
230 plugin = fts fts_xapian
233 fts_autoindex_exclude = \Junk
234 fts_autoindex_exclude2 = \Trash
236 # 2 and 20 are the NGram values for header fields, which means the
237 # keywords created for fields (To, Cc, ...) are between is 2 and 20 chars long.
238 # Full words are also added by default.
239 fts_xapian = partial=2 full=20 verbose=0
242 mail_plugins = $mail_plugins quota
244 quota = maildir:User quota
245 quota_rule = *:storage=256M
246 quota_rule2 = Trash:storage=+64M
247 quota_max_mail_size = 20M
248 #quota_exceeded_message = </path/to/quota_exceeded_message.txt
249 quota_warning = storage=95%% quota-warning 95 %u
250 quota_warning2 = storage=80%% quota-warning 80 %u
251 quota_warning3 = -storage=100%% quota-warning below %u
255 hostname = ${networking.domain}
256 mail_plugins = $mail_plugins sieve
257 postmaster_address = postmaster+dovecot+lda@${networking.domain}
258 syslog_facility = mail
260 lda_mailbox_autocreate = yes
261 lda_mailbox_autosubscribe = yes
264 mail_plugins = $mail_plugins sieve
265 postmaster_address = postmaster+dovecot+lmtp@${networking.domain}
268 process_min_avail = ${toString config.nix.maxJobs}
269 unix_listener /var/lib/postfix/queue/private/dovecot-lmtp {
270 user = ${postfix.user}
271 group = ${postfix.group}
276 # Let extension.sieve do the handling of the detail
277 #lmtp_save_to_detail_mailbox = yes
278 recipient_delimiter = ${postfix.recipientDelimiter}
282 # Most of the memory goes to mmap()ing files.
283 # You may need to increase this limit if you have huge mailboxes.
288 #inet_listener imap {
289 # address = 127.0.0.1
293 inet_listener imaps {
298 # Store METADATA information within user's HOME directory
299 mail_attribute_dict = file:%h/dovecot-attributes
300 # If you have Dovecot v2.2.8+ you may get a significant performance improvement with fetch-headers:
301 imapc_features = $imapc_features fetch-headers
303 #mail_max_userip_connections = 10
304 mail_plugins = $mail_plugins imap_acl imap_quota imap_sieve virtual
307 # DOC: https://wiki.dovecot.org/MailboxSettings
308 # Due to a bug in Dovecot v2.2.30+ if special-use flags are used,
309 # SPECIAL-USE needs to be added to post-login CAPABILITY response as RFC 6154 mandates.
310 imap_capability = +SPECIAL-USE
315 special_use = \Archive
319 special_use = \Drafts
321 mailbox "Brouillons" {
323 special_use = \Drafts
338 mailbox "Pourriels" {
350 mailbox "Sent Items" {
354 mailbox "Sent Messages" {
367 mailbox "Corbeille" {
375 comment = All messages from all mailboxes
380 comment = All messages from all mailboxes arrived in the past 48h
385 sieve_plugins = sieve_imapsieve sieve_extprograms
386 sieve_global_extensions = +vnd.dovecot.environment +vnd.dovecot.pipe
387 #sieve_extensions = +editheader
388 sieve = file:~/sieve;active=~/active.sieve
389 sieve_default = file:${stateDir}/sieve/global/default.sieve
390 sieve_default_name = main
391 sieve_pipe_bin_dir = ${sieve_pipe_bin_dir}/bin
392 sieve_max_script_size = 1M
393 sieve_quota_max_scripts = 0
394 sieve_quota_max_storage = 10M
395 #sieve_spamtest_max_value = 10
396 #sieve_spamtest_status_header = X-Spam-Score
397 #sieve_spamtest_status_type = strlen
398 #sieve_user_log = /var/log/dovecot/%d/sieve.%n.log
399 # Enables support for user Sieve scripts in IMAP
400 #imapsieve_url = sieve://mail.${networking.domain}:4190
402 # When a flag changes, spam or ham according to the \Junk or \NonJunk flags
403 imapsieve_mailbox1_name = *
404 imapsieve_mailbox1_causes = FLAG
405 imapsieve_mailbox1_before = file:${stateDir}/sieve/global/spam-or-ham.sieve
407 # From elsewhere to Junk folder
408 imapsieve_mailbox2_name = Pourriel
409 imapsieve_mailbox2_causes = COPY APPEND
410 imapsieve_mailbox2_before = file:${stateDir}/sieve/global/report-spam.sieve
412 # From Junk folder to elsewhere
413 imapsieve_mailbox3_name = *
414 imapsieve_mailbox3_from = Pourriel
415 imapsieve_mailbox3_causes = COPY
416 imapsieve_mailbox3_before = file:${stateDir}/sieve/global/report-ham.sieve
419 # Maximum number of ManageSieve connections allowed for a user from each IP address.
420 # NOTE: The username is compared case-sensitively.
421 mail_max_userip_connections = 10
423 # To fool ManageSieve clients that are focused on CMU's timesieved you can specify
424 # the IMPLEMENTATION capability that the dovecot reports to clients.
425 # For example: 'Cyrus timsieved v2.2.13'
426 managesieve_implementation_string = Dovecot Pigeonhole
428 # The maximum number of compile errors that are returned to the client upon script
429 # upload or script verification.
430 managesieve_max_compile_errors = 5
432 #mail_max_userip_connections = 10
433 #managesieve_implementation_string = Dovecot Pigeonhole
434 managesieve_max_compile_errors = 5
435 #managesieve_max_line_length = 65536
436 #managesieve_notify_capability = mailto
437 #managesieve_sieve_capability = fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date ihave
439 service managesieve-login {
440 inet_listener sieve {
445 # Number of connections to handle before starting a new process. Typically
446 # the only useful values are 0 (unlimited) or 1. 1 is more secure, but 0
447 # is faster. <doc/wiki/LoginProcess.txt>
450 # Number of processes to always keep waiting for more connections.
451 process_min_avail = 0
453 # If you set service_count=0, you probably need to grow this.
457 service quota-warning {
458 executable = script ${
459 pkgs.writeShellScript "quota-warning" ''
463 cat << EOF | ${pkgs.dovecot}/libexec/dovecot/dovecot-lda -d $USER -o
464 "plugin/quota=maildir:User quota:noenforcing"
465 From: postmaster@${networking.domain}
466 Subject: [WARNING] your mailbox is now $PERCENT% full.
468 Please remove some mails to make room for new ones.
472 # use some unprivileged user for executing the quota warnings
473 user = ${dovecot2.user}
474 unix_listener quota-warning {
479 mail_plugins = $mail_plugins virtual
480 #mail_max_userip_connections = 10
481 # Virtual namespace for the virtual INBOX.
482 # Use a global directory for dovecot-virtual files.
486 # location = virtual:''${dovecot-virtual-pop3}/pop3:INDEX=${stateDir}/index/%d/%n/virtual/pop3:LAYOUT=fs
489 pop3_client_workarounds =
490 pop3_fast_size_lookups = yes
491 pop3_lock_session = yes
492 pop3_no_flag_updates = yes
493 # Use GUIDs to avoid accidental POP3 UIDL changes instead of IMAP UIDs.
494 pop3_uidl_format = %g
500 inet_listener pop3s {