1 { pkgs, lib, config, machines, ... }:
3 inherit (builtins) hasAttr readFile;
4 inherit (pkgs.lib) unlinesAttrs;
5 inherit (config.users) users groups;
8 networking.firewall.enable = false;
9 security.lockKernelModules = false;
10 systemd.services.disable-kernel-module-loading.after = [ "nftables.service" ];
11 # echo -e "$(nix eval machines.losurdo.config.networking.nftables.ruleset)"
13 systemd.services.nftables.serviceConfig.TimeoutStartSec = "20";
14 networking.nftables = {
16 ruleset = lib.mkBefore ''
19 # Some .nix append rules here with: add rule inet filter net2fw ...
22 tcp dport {80,443} counter accept comment "HTTP"
23 udp dport 123 skuid ${users.systemd-timesync.name} counter accept comment "NTP"
24 tcp dport 9418 counter accept comment "Git"
26 # Some .nix append rules here with: add rule inet filter fw2net ...
29 # Some .nix append rules here with: add rule inet filter intra2fw ...
32 # Some .nix append rules here with: add rule inet filter fw2intra ...
35 # Some .nix append rules here with: add rule inet filter fwd-intra ...
39 type filter hook input priority 0
44 # accept traffic already established
45 ct state {established, related} accept
49 tcp dport 22 counter accept comment "SSH"
50 udp dport 60000-61000 counter accept comment "Mosh"
53 ip6 nexthdr icmpv6 icmpv6 type { destination-unreachable, packet-too-big, time-exceeded, parameter-problem, nd-router-advert, nd-neighbor-solicit, nd-neighbor-advert, mld-listener-query, nd-router-solicit } accept
54 ip protocol icmp icmp type { destination-unreachable, router-advertisement, time-exceeded, parameter-problem } accept
57 ip6 nexthdr icmpv6 icmpv6 type echo-request accept
58 ip protocol icmp icmp type echo-request accept
60 # Some .nix append gotos here with: add rule inet filter input iffname ... goto ...
63 type filter hook output priority 0
68 ct state {related,established} accept
71 icmp type echo-request counter accept comment "Ping"
72 tcp dport 22 counter accept comment "SSH"
74 # Some .nix append gotos here with: add rule inet filter output oifname ... goto ...
77 type filter hook forward priority 0