]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/fileSystems.nix
losurdo: fix initrd networking
[sourcephile-nix.git] / machines / losurdo / fileSystems.nix
1 { pkgs, lib, config, machineName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/systems/zfs.nix
5 ];
6
7 fileSystems."/" =
8 { device = "${machineName}/root";
9 fsType = "zfs";
10 };
11 boot.zfs.requestEncryptionCredentials = [ machineName ];
12
13 fileSystems."/home" =
14 { device = "${machineName}/home";
15 fsType = "zfs";
16 };
17
18 fileSystems."/home/julm" =
19 { device = "${machineName}/home/julm";
20 fsType = "zfs";
21 };
22
23 fileSystems."/home/julm/work" =
24 { device = "${machineName}/home/julm/work";
25 fsType = "zfs";
26 };
27
28 fileSystems."/nix" =
29 { device = "${machineName}/nix";
30 fsType = "zfs";
31 };
32
33 fileSystems."/var" =
34 { device = "${machineName}/var";
35 fsType = "zfs";
36 };
37
38 fileSystems."/var/cache" =
39 { device = "${machineName}/var/cache";
40 fsType = "zfs";
41 };
42
43 fileSystems."/var/log" =
44 { device = "${machineName}/var/log";
45 fsType = "zfs";
46 };
47
48 fileSystems."/var/lib/nginx" =
49 { device = "${machineName}/var/www";
50 fsType = "zfs";
51 };
52
53 fileSystems."/var/lib/postgresql" =
54 { device = "${machineName}/var/postgresql";
55 fsType = "zfs"; # with sync=always,
56 # though loading OpenConcerto's initial SQL
57 # takes 1m40s instead of 40s :\
58 };
59
60 fileSystems."/var/lib/transmission" =
61 { device = "${machineName}/var/torrents";
62 fsType = "zfs";
63 };
64
65 fileSystems."/var/tmp" =
66 { device = "${machineName}/var/tmp";
67 fsType = "zfs";
68 };
69
70 fileSystems."/mnt/key" =
71 { device = "/dev/disk/by-label/key";
72 fsType = "vfat";
73 options = [ "auto" "nofail" "uid=1000" "gid=users" "umask=111" "dmask=007" "utf8=yes" ];
74 };
75
76 }