]> Git — Sourcephile - sourcephile-nix.git/blob - servers/losurdo/system.nix
nftables: replace shorewall on losurdo
[sourcephile-nix.git] / servers / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 <nixpkgs/nixos/modules/profiles/hardened.nix>
5 ];
6
7 # This value determines the NixOS release with which your system is to be
8 # compatible, in order to avoid breaking some software such as database servers.
9 # You should change this only after NixOS release notes say you should.
10 system.stateVersion = "19.09"; # Did you read the comment?
11
12 # Avoid the use of systemd-run --user --scope tmux
13 # and let mosh work smoothly.
14 services.logind.killUserProcesses = false;
15
16 environment.systemPackages = with pkgs; [
17 cryptsetup
18 direnv
19 file
20 fio
21 gdb
22 git
23 gptfdisk
24 #hey
25 home-manager
26 lm_sensors
27 rsync
28 smartctl-tbw
29 socat
30 sanoid
31 iptables-nftables-compat
32 ];
33 }