]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet.nix
mermet: fix nsd
[sourcephile-nix.git] / servers / mermet.nix
1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 {pkgs, lib, config, options, nodes, resources, ...}:
6 let
7 inherit (builtins.extraBuiltins) pass;
8 in
9 {
10 # This value determines the NixOS release with which your system is to be
11 # compatible, in order to avoid breaking some software such as database
12 # servers. You should change this only after NixOS release notes say you should.
13 system.stateVersion = "19.09"; # Did you read the comment?
14
15 nixpkgs.overlays = import ../overlays.nix;
16
17 imports =
18 [ ../nixos/defaults.nix
19 mermet/apu2e4.nix
20 mermet/zfs.nix
21 mermet/lesptts.nix
22 mermet/shorewall.nix
23 mermet/unbound.nix
24 mermet/nsd.nix
25 ];
26
27 networking = rec {
28 hostName = "mermet";
29 domainBase = "sourcephile";
30 domain = "${domainBase}.fr";
31 };
32
33 users = {
34 mutableUsers = false;
35 users = {
36 root = rec {
37 initialPassword = password;
38 password = pass "servers/mermet/login/root";
39 openssh.authorizedKeys.keys = [
40 (pass "members/julm/ssh.pub")
41 ];
42 };
43 };
44 groups = {
45 };
46 };
47
48 environment = {
49 systemPackages = with pkgs; [
50 cryptsetup
51 fio
52 git
53 gptfdisk
54 lm_sensors
55 smartctl-tbw
56 socat
57 ];
58 };
59 }