1 { pkgs, lib, config, ... }:
2 let inherit (lib) types;
7 defaults/predictable-interface-names.nix
11 #binaryCaches = lib.mkForce [];
14 # Use gc.automatic to keep disk space under control.
18 options = "--delete-older-than 30d";
21 # WARNING: this is a hack to avoid copying Nixpkgs
22 # a second time into the Nix store.
23 # It makes only sense when Nixpkgs is already in the Nix store,
25 "nixpkgs=${toString pkgs.path}"
33 packageOverrides = pkgs: {
34 postfix = pkgs.postfix.override {
40 overlays = import ./overlays.nix;
43 documentation.nixos = {
44 enable = false; # NOTE: useless on a server, and CPU intensive.
48 timeZone = "Europe/Paris";
52 defaultLocale = "fr_FR.UTF-8";
56 font = "Lat2-Terminus16";
60 # Always try to start all the units (default.target)
61 # because systemd's emergency shell does not try to start sshd.
62 # https://wiki.archlinux.org/index.php/systemd#Disable_emergency_mode_on_remote_machine
63 systemd.enableEmergencyMode = false;
65 # This is a remote headless server: always reboot on a kernel panic,
66 # to not have to physically go power cycle the apu2e4.
67 # Which happens if the wrong ZFS password is used
68 # but the boot is manually forced to continue.
69 # Using kernelParams instead of kernel.sysctl
70 # sets this up as soon as the initrd.
71 boot.kernelParams = [ "panic=10" ];
73 boot.cleanTmpDir = true;
74 boot.tmpOnTmpfs = true;
79 passwordAuthentication = false;
91 #checkConfigurationOptions = false;
92 #etc.nixpkgs.source = (pkgs.runCommandLocal "pkgs.path" {propagatedBuildInputs=[pkgs.path]; buildInputs=[pkgs.path];} "mkdir $out");
93 systemPackages = with pkgs; [
94 pkgs.path # WARNING: this is a hack to register the path to Nixpkgs. See nix.nixPath.
113 pkgs.linuxPackages.cpupower
116 etc."inputrc".text = lib.readFile defaults/readline/inputrc;
121 interactiveShellInit = ''
122 bind '"\e[A":history-search-backward'
123 bind '"\e[B":history-search-forward'
125 # Ignore duplicate commands, ignore commands starting with a space
126 export HISTCONTROL=erasedups:ignorespace
127 export HISTSIZE=42000
129 # Append to the history instead of overwriting (good for multiple connections)
132 # Enable ** file pattern
135 # Convenient mkdir wrapper
136 mkcd() { mkdir -p "$1" && cd "$1"; }
142 ls = "ls --color=tty";
143 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
146 s-u="systemctl --user";
148 nixos-clean="sudo nix-collect-garbage -d";
149 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
150 nixos-rollback="sudo nixos-rebuild switch --rollback";
151 nixos-update="sudo nix-channel --update";
152 nixos-upgrade="sudo nixos-rebuild switch";
153 nixos-upstream="sudo nix-channel --list";
158 pinentryFlavor = "curses";