1 { pkgs, lib, config, ... }:
2 let inherit (lib) types;
7 ./defaults/predictable-interface-names.nix
11 autoOptimiseStore = true;
14 # Use gc.automatic to keep disk space under control.
18 options = "--delete-older-than 30d";
26 packageOverrides = pkgs: {
27 postfix = pkgs.postfix.override {
33 #overlays = import ../overlays.nix;
36 documentation.nixos = {
37 enable = false; # NOTE: useless on this machine, and CPU intensive.
41 timeZone = "Europe/Paris";
45 consoleFont = "Lat2-Terminus16";
47 defaultLocale = "fr_FR.UTF-8";
64 systemPackages = with pkgs; [
82 etc."inputrc".text = lib.readFile defaults/readline/inputrc;
87 interactiveShellInit = ''
88 bind '"\e[A":history-search-backward'
89 bind '"\e[B":history-search-forward'
91 # Ignore duplicate commands, ignore commands starting with a space
92 export HISTCONTROL=erasedups:ignorespace
95 # Append to the history instead of overwriting (good for multiple connections)
102 ls = "ls --color=tty";
103 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
106 s-u="systemctl --user";
108 nixos-clean="sudo nix-collect-garbage -d";
109 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
110 nixos-rollback="sudo nixos-rebuild switch --rollback";
111 nixos-update="sudo nix-channel --update";
112 nixos-upgrade="sudo nixos-rebuild switch";
113 nixos-upstream="sudo nix-channel --list";