]> Git — Sourcephile - sourcephile-nix.git/blob - servers/losurdo/system.nix
nix: replace nixops by shell scripts
[sourcephile-nix.git] / servers / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 {
3 # This value determines the NixOS release with which your system is to be
4 # compatible, in order to avoid breaking some software such as database servers.
5 # You should change this only after NixOS release notes say you should.
6 system.stateVersion = "19.09"; # Did you read the comment?
7
8 # Avoid the use of systemd-run --user --scope tmux
9 # and let mosh work smoothly.
10 services.logind.killUserProcesses = false;
11
12 environment.systemPackages = with pkgs; [
13 cryptsetup
14 direnv
15 file
16 fio
17 gdb
18 git
19 gptfdisk
20 #hey
21 home-manager
22 lm_sensors
23 rsync
24 smartctl-tbw
25 socat
26 sanoid
27 ];
28 }