1 # Run with : nix run -f tests.nix
2 # Debug with : nix -L run -f tests.nix driver -c nixos-test-driver
3 { system ? builtins.currentSystem
5 , overlays ? nixpkgs/overlays.nix
6 , pkgs ? import <nixpkgs> { inherit system config overlays; }
12 (import (pkgs.path + /nixos/lib/testing-python.nix)) {
14 extraConfigurations = [
16 # Propagate pkgs and its overlays to the VM,
17 # instead of reloading nixpkgs.
18 config.nixpkgs.pkgs = lib.mkDefault pkgs;
19 config.documentation.enable = false;
27 mermet = { ... }: { };
35 mermet.wait_for_unit("multi-user.target")
38 "mount -t tmpfs none /tmp/test",
39 "touch /tmp/test/hello",
40 "test -f /tmp/test/hello",