]> Git — Sourcephile - sourcephile-nix.git/blob - servers/losurdo/production/fileSystems.nix
losurdo: booting on that specific NVMe M.2 is not (yet?) supported
[sourcephile-nix.git] / servers / losurdo / production / fileSystems.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../base/zfs.nix
5 ];
6
7 # The 32-bit host id of the machine, formatted as 8 hexadecimal characters.
8 # You should try to make this id unique among your machines.
9 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
10 networking.hostId = "69c40b03";
11
12 /*
13 # Enable the (OpenSolaris-compatible) ZFS auto-snapshotting service.
14 services.zfs.autoSnapshot = {
15 enable = true;
16 frequent = ;
17 hourly = ;
18 daily = ;
19 weekly = ;
20 monthly = ;
21 };
22 */
23
24 boot.loader.grub.devices = [
25 #"/dev/disk/by-id/nvme-Samsung_SSD_970_EVO_Plus_250GB_S4EUNJ0N211426T"
26 "/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
27 ];
28
29 fileSystems."/boot" =
30 { device = "/dev/disk/by-partlabel/losurdo_sd_boot";
31 fsType = "ext2";
32 };
33
34 fileSystems."/boot/efi" =
35 { device = "/dev/disk/by-partlabel/losurdo_sd_efi";
36 fsType = "vfat";
37 };
38
39 /*
40 swapDevices =
41 [ { device = "/dev/disk/by-partlabel/losurdo_nvme_swap";
42 randomEncryption = {
43 enable = true;
44 cipher = "aes-xts-plain64";
45 source = "/dev/urandom";
46 };
47 }
48 ];
49 */
50
51 fileSystems."/" =
52 { device = "losurdo_sd/root";
53 fsType = "zfs";
54 };
55
56 fileSystems."/home" =
57 { device = "losurdo_sd/home";
58 fsType = "zfs";
59 };
60
61 fileSystems."/nix" =
62 { device = "losurdo_sd/nix";
63 fsType = "zfs";
64 };
65
66 fileSystems."/var" =
67 { device = "losurdo_sd/var";
68 fsType = "zfs";
69 };
70
71 fileSystems."/var/cache" =
72 { device = "losurdo_sd/var/cache";
73 fsType = "zfs";
74 };
75
76 fileSystems."/var/log" =
77 { device = "losurdo_sd/var/log";
78 fsType = "zfs";
79 };
80
81 fileSystems."/var/tmp" =
82 { device = "losurdo_sd/var/tmp";
83 fsType = "zfs";
84 };
85 }