1 { pkgs, lib, config, inputs, hostName, ... }:
4 (inputs.julm-nix + "/nixos/profiles/zfs.nix")
9 { device = "bpool/boot";
14 device = "rpool/root";
15 fsType = "zfs"; # TODO: options = [ "zfsutil" ];
18 # This will automatically load the zfs password prompt on login
19 # and kill the other prompt so boot can continue
20 # The pkill zfs kills the zfs load-key from the console
21 # allowing the boot to continue.
22 boot.initrd.network.postCommands = ''
23 echo >>/root/.profile "zfs load-key rpool && pkill zfs"
25 boot.zfs.requestEncryptionCredentials = lib.mkForce [ "rpool" ];
26 #boot.zfs.requestEncryptionCredentials = [ hostName ];
29 { device = "rpool/home";
33 fileSystems."/home/julm" =
34 { device = "rpool/home/julm";
38 fileSystems."/home/julm/log" =
39 { device = "rpool/home/julm/log";
43 fileSystems."/home/julm/mail" =
44 { device = "rpool/home/julm/mail";
49 { device = "rpool/nix";
54 { device = "rpool/var";
58 fileSystems."/var/cache" =
59 { device = "rpool/var/cache";
63 fileSystems."/var/log" =
64 { device = "rpool/var/log";
68 fileSystems."/var/tmp" =
69 { device = "rpool/var/tmp";
73 fileSystems."/var/www" =
74 { device = "rpool/var/www";