1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 { pkgs, lib, config, options, ... }@attrs:
7 inherit (builtins) getEnv hasAttr readFile;
8 inherit (builtins.extraBuiltins) pass pass-chomp;
9 inherit (config.users) users;
12 # This value determines the NixOS release with which your system is to be
13 # compatible, in order to avoid breaking some software such as database servers.
14 # You should change this only after NixOS release notes say you should.
15 system.stateVersion = "19.09"; # Did you read the comment?
18 (./. + ("/" + getEnv "LOSURDO_DEPLOYMENT" + ".nix"))
20 ../../base/unbound.nix
25 ] ++ lib.optionals (! hasAttr "nodes" attrs) [
32 domainBase = "sourcephile";
33 domain = "${domainBase}.fr";
37 environment.etc."sudo.conf".text = ''
38 Debug sudo /var/log/sudo_debug.log all@debug
39 Debug sudoers.so /var/log/sudo_debug.log all@debug
43 systemd.coredump.enable = true;
46 enableDebugInfo = true;
47 systemPackages = with pkgs; [