]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/networking/ssh.nix
carotte: use passwordFile for unattended decryption
[sourcephile-nix.git] / hosts / losurdo / networking / ssh.nix
1 { pkgs, lib, config, hosts, ... }:
2 {
3 /* Wireguard is used instead
4 systemd.services.ssh-mermet-reverse = {
5 after = [ "network-online.target" ];
6 wantedBy = [ "multi-user.target" ];
7 serviceConfig = {
8 Type = "simple";
9 # Require services.openssh.gatewayPorts = "clientspecified";
10 # on the target.
11 ExecStart = ''${pkgs.openssh}/bin/ssh -v -g -N -T \
12 -o ServerAliveInterval=10 \
13 -o ExitOnForwardFailure=yes \
14 -R *:10022:localhost:22 \
15 ${hosts.mermet.extraArgs.ipv4}
16 '';
17 Restart = "always";
18 RestartSec = "5s";
19 };
20 };
21 */
22 boot.initrd.network.ssh = {
23 enable = true;
24 port = 2222;
25 authorizedKeys = config.users.users.root.openssh.authorizedKeys.keys;
26 hostKeys = [ "/root/initrd/ssh.key" ];
27 extraConfig = ''
28 '';
29 };
30 services.openssh = {
31 forwardX11 = true;
32 };
33 programs.ssh = {
34 extraConfig = ''
35 Compression = yes
36 '';
37 };
38 services.upnpc.redirections =
39 [
40 { description = "SSH";
41 externalPort = 22; protocol = "TCP"; duration = 30 * 60;
42 service.wantedBy = ["sshd.service"];
43 service.partOf = ["sshd.service"];
44 }
45 { description = "Mosh"; externalPort = 60000; protocol = "UDP"; duration = 30 * 60; service.wantedBy = ["sshd.service"]; }
46 { description = "Mosh"; externalPort = 60001; protocol = "UDP"; duration = 30 * 60; service.wantedBy = ["sshd.service"]; }
47 { description = "Mosh"; externalPort = 60002; protocol = "UDP"; duration = 30 * 60; service.wantedBy = ["sshd.service"]; }
48 { description = "Mosh"; externalPort = 60003; protocol = "UDP"; duration = 30 * 60; service.wantedBy = ["sshd.service"]; }
49 ] ++ [
50 { description = "SSH (boot)";
51 externalPort = 2222; protocol = "TCP"; duration = 0;
52 service.wantedBy = ["sshd.service"];
53 }
54 ];
55 }