]> Git — Sourcephile - sourcephile-nix.git/blob - nixos/profiles/systems/builder.nix
nix: avoid sending nixpkgs on non-builder target
[sourcephile-nix.git] / nixos / profiles / systems / builder.nix
1 { inputs, pkgs, lib, config, ... }:
2 {
3 nix.nixPath = [
4 "nixpkgs=/etc/nixpkgs:nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
5 ];
6 nix.extraOptions = "experimental-features = nix-command flakes";
7 # Note that this will make the target system download Nixpkgs.
8 nix.registry.nixpkgs.flake = pkgs.path;
9 # WARNING: this is a hack to avoid copying Nixpkgs
10 # a second time into the Nix store.
11 # It makes only sense when Nixpkgs is already in the Nix store,
12 # and is registered.
13 environment.etc."nixpkgs".source = pkgs.path;
14 environment.etc."nixpkgs-overlays".source =
15 pkgs.writeTextDir "overlays.nix" ''
16 import ${inputs.self + "/nixpkgs/overlays.nix"} ++
17 import ${inputs.julm-nix + "/nixpkgs/overlays.nix"}
18 '';
19 }