]> Git — Sourcephile - sourcephile-nix.git/blob - servers/losurdo/system.nix
nix: revamp nixos/{base => profiles}/
[sourcephile-nix.git] / servers / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 {
3 # This value determines the NixOS release with which your system is to be
4 # compatible, in order to avoid breaking some software such as database servers.
5 # You should change this only after NixOS release notes say you should.
6 system.stateVersion = "19.09"; # Did you read the comment?
7
8 # Avoid the use of systemd-run --user --scope tmux
9 # and let mosh work smoothly.
10 services.logind.killUserProcesses = false;
11
12 services.unbound.enable = true;
13
14 environment.systemPackages = with pkgs; [
15 cryptsetup
16 direnv
17 file
18 fio
19 gdb
20 git
21 gptfdisk
22 #hey
23 home-manager
24 lm_sensors
25 rsync
26 smartctl-tbw
27 socat
28 sanoid
29 #iptables-nftables-compat
30 ];
31 }