1 { config, inputs, ... }:
7 (inputs.julm-nix + "/nixos/profiles/wireguard/${wgIface}.nix")
10 systemd.services."wireguard-${wgIface}".serviceConfig.LoadCredentialEncrypted = [
11 "privateKey:${./. + "/${wgIface}/privateKey.cred"}"
13 networking.wireguard.${wgIface}.peers = {
14 aubergine.enable = true;
16 losurdo.enable = true;
20 networking.nftables.ruleset = ''
23 tcp dport ssh counter accept comment "SSH"
24 udp dport 60000-60100 counter accept comment "Mosh"
27 tcp dport ssh counter accept comment "SSH"
28 udp dport 60000-60100 counter accept comment "Mosh"