1 { pkgs, lib, config, machineName, ... }:
4 ../../nixos/profiles/systems/zfs.nix
8 { device = "${machineName}/root";
13 { device = "${machineName}/home";
17 fileSystems."/home/julm" =
18 { device = "${machineName}/home/julm";
22 fileSystems."/home/julm/work" =
23 { device = "${machineName}/home/julm/work";
28 { device = "${machineName}/nix";
33 { device = "${machineName}/var";
37 fileSystems."/var/cache" =
38 { device = "${machineName}/var/cache";
42 fileSystems."/var/log" =
43 { device = "${machineName}/var/log";
47 fileSystems."/var/lib/nginx" =
48 { device = "${machineName}/var/www";
52 fileSystems."/var/lib/postgresql" =
53 { device = "${machineName}/var/postgresql";
54 fsType = "zfs"; # with sync=always,
55 # though loading OpenConcerto's initial SQL
56 # takes 1m40s instead of 40s :\
59 fileSystems."/var/lib/transmission" =
60 { device = "${machineName}/var/torrents";
64 fileSystems."/var/tmp" =
65 { device = "${machineName}/var/tmp";
69 fileSystems."/mnt/key" =
70 { device = "/dev/disk/by-label/key";
72 options = [ "uid=1000" "gid=users" "umask=111" "dmask=007" "utf8=yes" ];