1 { pkgs, lib, config, ... }:
2 let inherit (builtins) listToAttrs;
3 inherit (builtins.extraBuiltins) pass;
5 inherit (pkgs.lib) unlinesAttrs;
6 inherit (config) networking;
7 inherit (config.services) rspamd;
10 options.services.rspamd.dkim = {
11 enable = lib.mkEnableOption "rspamd DKIM material";
12 domains = lib.mkOption {
14 type = types.attrsOf (types.submodule {
16 selector = lib.mkOption {
18 description = ''Current selector'';
20 selectors = lib.mkOption {
22 description = ''Available selectors'';
23 type = types.attrsOf (types.submodule {
27 description = ''Private key'';
31 description = ''DNS record'';
41 config = lib.mkIf rspamd.dkim.enable {