1 { pkgs, lib, config, ... }:
5 gnupg = super.gnupg.override {
6 # Wants polkit which wants spidermonkey (slow to compile)
9 systemd = super.systemd.override {
10 # Wants tpm2-tss which does not cross-compile
12 # Does not cross-compile :(
15 # https://logs.nix.samueldr.com/nixos/2019-07-23#2416964;
16 xorg = super.xorg.overrideScope' (ofinal: osuper: {
17 fontadobe100dpi = final.hello;
18 fontadobe75dpi = final.hello;
19 fontcursormisc = final.hello;
20 fontmiscmisc = final.hello;
22 # Perl's ModuleBuild does not cross-compile
23 # https://github.com/NixOS/nixpkgs/issues/66741#issuecomment-944831760
24 xdg-utils = final.hello;
25 procmail = final.hello;
26 noto-fonts-emoji = final.hello;
27 x11_ssh_askpass = final.hello;
28 dconf = super.dconf.overrideAttrs (old: {
31 # Need gobject-instrospection which does not cross-compile
33 # Depends on judy which does not cross-compile
34 stress-ng = final.hello;
36 # Fails to cross-compile: perl5.34.0-IO-Tty-armv7l-unknown-linux-gnueabihf
38 # error: Error loading target specification:
39 # Could not find specification for target "armv7l-unknown-linux-gnueabihf".
40 # Run `rustc --print target-list` for a list of built-in targets
41 gparted = final.hello;
44 #environment.noXlibs = true;
45 fonts.fontconfig.enable = false;
46 # lesspipe does not cross-compile
47 programs.less.enable = lib.mkForce false;
48 programs.mosh.enable = false;
49 programs.traceroute.enable = false;
50 security.apparmor.enable = false;
51 services.udisks2.enable = false;