]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/fileSystems.nix
zfs: increase zfs_arc_max to 1.5G
[sourcephile-nix.git] / machines / losurdo / fileSystems.nix
1 { pkgs, lib, config, machineName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/systems/zfs.nix
5 ];
6
7 boot.kernelParams = [
8 # Use arc_summary to print stats
9 "zfs.zfs_arc_max=${toString (1500 * 1024 * 1024)}" # bytes
10 ];
11
12 fileSystems."/" =
13 { device = "${machineName}/root";
14 fsType = "zfs";
15 };
16
17 fileSystems."/home" =
18 { device = "${machineName}/home";
19 fsType = "zfs";
20 };
21
22 fileSystems."/home/julm" =
23 { device = "${machineName}/home/julm";
24 fsType = "zfs";
25 };
26
27 fileSystems."/home/julm/work" =
28 { device = "${machineName}/home/julm/work";
29 fsType = "zfs";
30 };
31
32 fileSystems."/nix" =
33 { device = "${machineName}/nix";
34 fsType = "zfs";
35 };
36
37 fileSystems."/var" =
38 { device = "${machineName}/var";
39 fsType = "zfs";
40 };
41
42 fileSystems."/var/cache" =
43 { device = "${machineName}/var/cache";
44 fsType = "zfs";
45 };
46
47 fileSystems."/var/log" =
48 { device = "${machineName}/var/log";
49 fsType = "zfs";
50 };
51
52 fileSystems."/var/lib/nginx" =
53 { device = "${machineName}/var/www";
54 fsType = "zfs";
55 };
56
57 fileSystems."/var/lib/postgresql" =
58 { device = "${machineName}/var/postgresql";
59 fsType = "zfs"; # with sync=always,
60 # though loading OpenConcerto's initial SQL
61 # takes 1m40s instead of 40s :\
62 };
63
64 fileSystems."/var/lib/transmission" =
65 { device = "${machineName}/var/torrents";
66 fsType = "zfs";
67 };
68
69 fileSystems."/var/tmp" =
70 { device = "${machineName}/var/tmp";
71 fsType = "zfs";
72 };
73 }