1 { pkgs, lib, config, ... }:
4 inherit (builtins.extraBuiltins) pass git;
5 inherit (pkgs.lib) unlinesAttrs types;
6 inherit (config) networking;
7 inherit (config.services) nsd rspamd;
8 # Use the Git commit time of the ${domain}.nix file to set the serial number.
9 # WARNING: the ${domain}.nix must be committed into Git for this to work.
10 serial = domain: toString (git ./. [ "log" "-1" "--format=%ct" "--" (domain + ".nix") ]);
12 serial = file: lib.removeSuffix "\n" (readFile
13 (pkgs.runCommand "zone-serial"
14 { buildInputs = [ pkgs.git ];
15 buildDepends = [ (./. + file) ];
16 preferLocalBuild = true;
17 allowSubstitutes = false;
20 ${pkgs.git}/bin/git log -1 --format="%ct" -- ${file} >$out
23 # FIXME: make dedicated config options
24 #ipv4 = (elemAt networking.interfaces.enp1s0.ipv4.addresses 0).address;
25 mermetIPv4 = "80.67.180.129";
26 domain = "sourcephile.fr";
27 #ipv6 = (elemAt networking.interfaces.enp1s0.ipv6.addresses 0).address;
28 sourcephileZone = domain: ''
31 mermet A ${mermetIPv4}
32 autoconfig A ${mermetIPv4}
40 submission A ${mermetIPv4}
43 ; SPF (Sender Policy Framework)
44 @ 3600 IN SPF "v=spf1 mx ip4:${mermetIPv4} -all"
45 @ 3600 IN TXT "v=spf1 mx ip4:${mermetIPv4} -all"
51 _git._tcp.git 18000 IN SRV 0 0 9418 git
55 environment.systemPackages = [
56 (pkgs.bind.override { enablePython = true; })
58 services.nsd.zones."${domain}" = {
59 # DOC: https://docs.gandi.net/en/domain_names/advanced_users/secondary_nameserver.html
60 # DOC: https://www.sidn.nl/en/dnssec/dnssec-signatures-in-bind-named
61 provideXFR = [ "217.70.177.40 NOKEY" ];
62 # Not allowed by 217.70.177.40
63 #notify = [ "217.70.177.40 NOKEY" ];
65 # TODO: increase the TTL once things have settled down
70 ; SOA (Start Of Authority)
72 ${serial domain} ; Serial number
75 1000h ; Expire (1000h)
83 + sourcephileZone "${domain}";