1 { pkgs, lib, config, ... }:
2 let inherit (lib) types;
7 ./defaults/predictable-interface-names.nix
11 #binaryCaches = lib.mkForce [];
14 # Use gc.automatic to keep disk space under control.
18 options = "--delete-older-than 30d";
21 "nixpkgs=${pkgs.path}"
29 packageOverrides = pkgs: {
30 postfix = pkgs.postfix.override {
36 #overlays = import ../overlays.nix;
39 documentation.nixos = {
40 enable = false; # NOTE: useless on a server, and CPU intensive.
43 # Clean /tmp automatically on boot.
44 boot.cleanTmpDir = true;
47 timeZone = "Europe/Paris";
51 defaultLocale = "fr_FR.UTF-8";
55 font = "Lat2-Terminus16";
62 passwordAuthentication = false;
74 systemPackages = with pkgs; [
94 etc."inputrc".text = lib.readFile defaults/readline/inputrc;
99 interactiveShellInit = ''
100 bind '"\e[A":history-search-backward'
101 bind '"\e[B":history-search-forward'
103 # Ignore duplicate commands, ignore commands starting with a space
104 export HISTCONTROL=erasedups:ignorespace
105 export HISTSIZE=42000
107 # Append to the history instead of overwriting (good for multiple connections)
114 ls = "ls --color=tty";
115 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
118 s-u="systemctl --user";
120 nixos-clean="sudo nix-collect-garbage -d";
121 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
122 nixos-rollback="sudo nixos-rebuild switch --rollback";
123 nixos-update="sudo nix-channel --update";
124 nixos-upgrade="sudo nixos-rebuild switch";
125 nixos-upstream="sudo nix-channel --list";