9 let extraArgs_ = extraArgs;
11 baseModules = map import (lib.findFiles ".*\\.nix" ./modules );
13 _file = ./modules.nix;
16 _module.args.pkgs = lib.mkIf (pkgs_ != null) (lib.mkForce pkgs_);
21 # Merge the option definitions in all modules,
22 # forming the full system configuration.
23 inherit (lib.evalModules {
26 modules = modules ++ baseModules ++ [ pkgsModule ];
29 #specialArgs = { modulesPath = config/modules.nix; } // specialArgs;
32 # These are the extra arguments passed to every module.
33 # In particular, Nixpkgs is passed through the "pkgs" argument.
34 extraArgs = extraArgs_ // {
39 inherit (config._module.args) pkgs;