]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/carotte.nix
knot: fix preStart after hardening
[sourcephile-nix.git] / hosts / carotte.nix
1 # NixOS configuration of carotte.sourcephile.fr
2 { inputs, hostName, ... }:
3 {
4 system = "x86_64-linux";
5 modules = [
6 {
7 config._module.args = {
8 CPUs = 2;
9 };
10 }
11 ../nixos/defaults.nix
12 ../nixos/profiles/systems/debug.nix
13 #carotte/fileSystems.nix
14 carotte/hardware.nix
15 carotte/networking.nix
16 carotte/security.nix
17 carotte/system.nix
18 carotte/users.nix
19 (inputs.secrets + "/hosts/${hostName}/users.nix")
20 carotte/xserver.nix
21 ];
22 }