1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 {pkgs, lib, config, options, nodes, resources, ...}:
7 inherit (builtins.extraBuiltins) pass;
10 # This value determines the NixOS release with which your system is to be
11 # compatible, in order to avoid breaking some software such as database
12 # servers. You should change this only after NixOS release notes say you should.
13 system.stateVersion = "19.09"; # Did you read the comment?
15 nixpkgs.overlays = import ../overlays.nix;
18 [ ../nixos/defaults.nix
29 domainBase = "sourcephile";
30 domain = "${domainBase}.fr";
37 initialPassword = password;
38 password = pass "servers/mermet/login/root";
39 openssh.authorizedKeys.keys = [
40 (pass "members/julm/ssh.pub")
49 systemPackages = with pkgs; [