2 nixpkgs_channel = builtins.getEnv "nixpkgs_channel";
3 originNixpkgs = import (.config/nixpkgs-channel + ("/" + nixpkgs_channel + ".nix"));
4 originPkgs = import originNixpkgs {
5 config = {}; # Make the config pure, ignoring user's config.
8 remoteNixpkgsPatches = [
10 { meta.description = "nsd : use types.lines where appropriate";
11 url = "https://github.com/NixOS/nixpkgs/pull/78968.diff";
12 sha256 = "11bqq1g1ax6i7xghihyhklmqpsq3njalardp6nvzphkjgxrypb47";
14 { meta.description = "shorewall: init at 5.2.3.3";
15 url = "https://github.com/NixOS/nixpkgs/pull/46131.diff";
16 sha256 = "0mfzlcr23ni5spnwksmmls50sw10alqbr5j6hjrwp9i30z0419yx";
19 { meta.description = "Dovecot plugin for Full Text Search (FTS) with Xapian";
20 url = "https://github.com/NixOS/nixpkgs/pull/78780.diff";
21 sha256 = "053md69ryybj27cp0xdfrza48zyzpblk6wvb2m2dbs9hm0gmcwc4";
23 /* Disabled because it triggers the local build of too many reverse-dependencies
24 { meta.description = "openldap: enable sha2 and pbkdf2 modules";
25 url = "https://github.com/NixOS/nixpkgs/pull/79286.diff";
26 sha256 = "0y255x74qksqy7fm4bdwlknhm3s55vgfgbv4dd7580p4lcavya0m";
30 { meta.description = "Replace simp-le with lego and support DNS-01 challenge";
31 url = "https://github.com/NixOS/nixpkgs/pull/77578.diff";
32 sha256 = "15zs2146zh54jg1gywrcwyqxpx7izc35vlakk3cvrlqwwsvlr2rf";
35 { meta.description = "dstat: fix pluginpath";
36 url = "https://github.com/NixOS/nixpkgs/pull/80151.diff";
37 sha256 = "0jjw2gvp7b7v2n2m2d6yj0gw711j6p9lyjf5ywp2y9ql6905qf4b";
40 { meta.description = "shorewall: fix warnings due to types.loaOf being deprecated";
41 url = "https://github.com/NixOS/nixpkgs/pull/80154.diff";
42 sha256 = "0b216m1rib3jl6s3r5cbkd5h1bfhppikg4cz9ayr1fspsflr3bci";
44 { meta.description = "shorewall: fix RestartTriggers";
45 url = "https://github.com/NixOS/nixpkgs/pull/81774.diff";
46 sha256 = "14drpym2mq9gq505psjzqq23gv0wkbwrrvh438h5jirzcym3467a";
50 localNixpkgsPatches = [
53 nixpkgs = originPkgs.applyPatches {
54 name = "nixpkgs-patched";
56 patches = map originPkgs.fetchpatch remoteNixpkgsPatches ++ localNixpkgsPatches;
58 patch=$(printf '%s\n' ${builtins.concatStringsSep " "
59 (map (p: p.sha256) remoteNixpkgsPatches ++ localNixpkgsPatches)} |
60 sort | sha256sum | cut -c -7)
61 echo "+patch-$patch" >.version-suffix
64 pkgs = import nixpkgs {
65 config = {}; # Make the config pure, ignoring user's config.
66 overlays = import ./overlays.nix;
70 nixos = pkgs.nixos {};
71 # Configuration of shell/modules/
72 configuration = {config, ...}: {
77 auto-optimise-store = true
85 gnupgHome = toString ../sec/gnupg;
86 keys = import shell/openpgp.nix;
89 trusted-key 0xB2450D97085B7B8C
94 opensslHome = toString ../sec/openssl;
95 certificates = import shell/x509.nix;
98 # WARNING: nixops uses its own ssh, not this one.
101 Ciphers aes256-gcm@openssh.com,aes128-gcm@openssh.com,aes256-ctr
105 ControlPath ${builtins.toString ../sec/ssh}/ssh-%h-%p-%r.socket
107 #SSAPIAuthentication no
109 StrictHostKeyChecking yes
110 UserKnownHostsFile ${builtins.toString ../sec/ssh/known_hosts}
118 # Using modules enables to separate specific configurations
119 # from reusable code in shell/modules.nix and shell/modules/
120 # which may find its way in another git repository one day.
122 (import shell/modules.nix {
124 modules = [ configuration ];
127 # Utility to query the Nix files like nixops show-option
128 # but without requiring a nixops database, and not limited to config entries.
129 pwd = toString (./. + "");
130 sourcephile-nix-get = pkgs.writeShellScriptBin "sourcephile-nix-get" ''
131 nix-instantiate --read-write-mode \
132 --arg networkExprs "[${pwd}/servers.nix ${pwd}/servers/production.nix]" \
133 --arg args '{}' --argstr "uuid" whatever \
134 --argstr deploymentName production "<nixops/eval-machine-info.nix>" \
135 --eval-only --strict --arg checkConfigurationOptions false -A "$@"
137 sourcephile-shred-tmp = pkgs.writeShellScriptBin "sourcephile-shred-tmp" ''
138 # Cleanup "../sec/tmp/"
139 # This is done when entering the nix-shell
140 # because direnv already hooks trap EXIT.
142 test ! -e sec/tmp || {
143 find sec/tmp -type f -exec shred -fu {} +
149 name = "sourcephile-nix";
151 #preferLocalBuild = true;
152 #allowSubstitutes = false;
153 buildInputs = modules.nix-shell.buildInputs ++ [
155 sourcephile-shred-tmp
156 nixos.nixos-generate-config
190 #pkgs.rxvt_unicode.terminfo
209 #enableParallelBuilding = true;
211 echo >&2 "nix: running shellHook"
214 PATH=$NIX_SHELL_PATH:$PATH
215 export NIX_PATH="nixpkgs=${toString pkgs.path}:nixpkgs-overlays="$PWD"/overlays:nixops=${toString pkgs.nixops}/share/nix/nixops"
217 # Since the .envrc calls this shellHook
218 # the EXIT trap cannot be freely used
219 # because it's already used by direnv,
220 # hence shred at startup, which is not ideal.
221 sourcephile-shred-tmp
223 ${modules.nix-shell.shellHook}
226 export PASSWORD_STORE_DIR="$PWD"/../sec/pass
229 export GPG_TTY=$(tty)
230 gpg-connect-agent updatestartuptty /bye >/dev/null
233 #export NIXOPS_DEPLOYMENT="staging"
234 export MERMET_DEPLOYMENT=production
235 export LOSURDO_DEPLOYMENT=production
236 export NIXOPS_STATE="$PWD"/../sec/nixops/state.nixops
237 NIXOPS_OPTS+=" --show-trace"
241 #export DISNIXOS_USE_NIXOPS=1
242 #export DISNIX_CLIENT_INTERFACE=disnix-nixops-client
243 #export DISNIX_PROFILE=default
244 #export DISNIX_TARGET_PROPERTY=hostname
245 #export DYSNOMIA_STATEDIR="$PWD"/../sec/dysnomia