]> Git — Sourcephile - sourcephile-nix.git/blob - machines/mermet/system.nix
nix: daily GC on mermet
[sourcephile-nix.git] / machines / mermet / system.nix
1 { pkgs, lib, config, ... }:
2 {
3 # This value determines the NixOS release with which your system is to be
4 # compatible, in order to avoid breaking some software such as database servers.
5 # You should change this only after NixOS release notes say you should.
6 system.stateVersion = "19.09"; # Did you read the comment?
7
8 services.unbound.enable = true;
9
10 nix.gc.dates = "daily";
11 nix.gc.options = "--delete-older-than 2d";
12
13 environment.systemPackages = with pkgs; [
14 cryptsetup
15 direnv
16 file
17 fio
18 gdb
19 git
20 gptfdisk
21 #hey
22 home-manager
23 lm_sensors
24 rsync
25 smartctl-tbw
26 socat
27 thttpd
28 #iptables-nftables-compat
29 ];
30 }