1 { pkgs, lib, config, ... }:
4 nixpkgs.hostPlatform = {
5 system = "x86_64-linux";
6 config = "x86_64-unknown-linux-gnu";
9 hardware.cpu.amd.updateMicrocode = true;
11 # Too CPU hungry for this hardware, for too little Mio saved
12 nix.settings.auto-optimise-store = false;
14 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
16 # https://insanity.industries/post/sata-power-consumption/
17 services.udev.extraRules = ''
18 SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
25 configurationLimit = 1;
27 # In case canTouchEfiVariables doesn't work
28 #efiInstallAsRemovable = true;
30 # Completed in the importing configuration
34 { devices = [ "${disk_id}" ];
35 path = "/boot${bootnum}";
42 canTouchEfiVariables = true;
43 efiSysMountPoint = "/boot/efi";
49 availableKernelModules = [
57 # Make the AES modules available at initrd,
58 # to speedup the deciphering of the root.
65 # Enable boot from SD card
73 "console=ttyS0,115200n8"
74 # Avoids huge slow downs, especially with postgresql.
75 "zfs.zfs_arc_max=${toString (1024 * 1024 * 1024)}" # bytes
78 environment.systemPackages = [